This project has moved and is read-only. For the latest updates, please go here.
1
Vote

Running UWP apps on a separate partition

description

I have used VeraCrypt to encrypt all of my drives and have noticed that UWP apps not installed on the OS drive no longer start. If I move them to the C drive there is no issue, but they normally reside on a 4TB drive and now refuse to open. Checking the event viewer comes up with this error.
Activation of app Microsoft.OpusPG_8wekyb3d8bbwe!OpusReleaseFinal failed with error: The app didn't start. See the Microsoft-Windows-TWinUI/Operational log for additional information.
Checking that section comes up with a few other errors.
Activation via contract helper of the app Microsoft.OpusPG_8wekyb3d8bbwe!OpusReleaseFinal for the Windows.Launch contract failed with Server execution failed.

Activation of the app Microsoft.OpusPG_8wekyb3d8bbwe!OpusReleaseFinal for the Windows.Launch contract failed with error: The app didn't start..

ActivateApplicationForContractByAppIdAsUserWithHost of the app Microsoft.OpusPG_8wekyb3d8bbwe!OpusReleaseFinal for the Windows.Launch contract failed with The app didn't start..
After using Google to see if I could find an answer I've come up empty handed. I assume this has something to do with the way Windows tries to access these files and start the sandbox for them that doesn't work out with a veracrypt encrypted partition. If there is any way to fix this short of making a separate unencrypted partition that would be very helpful. Thanks.

comments

KingJ50 wrote Jan 1 at 7:17 PM

Also, it should probably be mentioned that I tried moving the apps to an unencrypted external drive and they worked without issue so it seems it is somehow related to veracrypt.