This project has moved and is read-only. For the latest updates, please go here.

Veracrypt cannot decrypt hard drive after moving to another system

Topics: Technical Issues
Apr 22, 2017 at 12:16 AM
I had a computer system with an SSD and a spinning hard disk drive. The OS was installed to the SDD unencrypted and my personal files were installed on the HDD. The HDD was encrypted using Veracrypt as a device-hosted (non-system) volume, as opposed to a file-hosted volume.

Since then the the SSD has failed and I can longer boot the system. While I can live with the loss of the SDD, the HDD has important data which I really need to recover. I've connected it to another system via SATA. Windows can see the drive and I can assign it a drive letter. However, when I try to decrypt with Veracrypt, I get the following message:
Operation failed due to one or more of the following:

 - Incorrect password.
 - Incorrect Volume PIM number.
 - Incorrect PRF (hash).
 - Not a valid volume.

Source: MountVolume:7763
I'm pretty certain the password is correct. I've tried using the backup volume header via mount options, plus restoring the volume header via Tools > Restore Volume Header but neither option works. I don't have a rescue disk.

Any suggestions as what else I can try to do to recover the data?
Apr 24, 2017 at 9:51 PM
Edited Apr 24, 2017 at 9:54 PM
I have the nearly same problem, but on a different situation.

I used TrueCrypt and configured it 5 years ago. I am not sure what I configured in detail, but I have the same drives configuration as the topic starter:

Windows 7:
C: SSD: System SSD PRE-Boot authetification
D: HDD: Normal Device was also encrypted.

I also only had one Password to enter in pre-boot Authentication. So I entered only one password in pre-boot to decrpyt and mount both (c: and d:). The d: HDD normal Device is also auto-monted on every boot.

Now I used TrueCrypt GUI to change the Password. I have never updated TrueCrypt, so I have the same TrueCrypt installed as 5 years ago.
I think it truecrypt password change has the same construct as veracrypt now has.
After Changing the password of the C: SDD System drive, I did a reboot. After reboot can enter my newly changed password correctly and my system is booting fine. Not problem for my booting system SSD. But now my D: HDD is missing. I have no d: drive anymore and also can't encrypt the HDD device with truecrypt. Any idea how?

When I select d: as device and try to mount, TC says that the password is wrong or did not find a TC volume. I am very sure about the password, because I entered it for 5 years. Now I can't mount d: hdd with old password and also not with new password. No PW works for d: now.

I think both volumes had the same Password last 5 yraes, because I only have entered one password on pre-boot auth. But when I try to mound the HDD device now, and enter my old password, I only get the error message. What should I do to get my missing D: drive back and readable and again?

And chance of getting more infos for you. How can I get more information an d: about finding some truecrypt volumes?

My situation is not 100% the same as topic starter, but I thing it's the same point. We can both boot our system drive c: and can't mount our old hdd data drive d:.

When somebody has a c: system device in pre-boot auth and also a auto-mounted encrypted d: device, what happened exactly when changing the password for the c: system drive in the GUI?

Best regards
Apr 30, 2017 at 10:12 AM
Edited Apr 30, 2017 at 10:16 AM
Even when I didn' tget a tipp, here is my solution.

At Topic starter:
Perhaps your HDD was also a non-System drive, as System favorite? And you had entered your PW every time at System boot?
And perhaps you have also, after booting your OS, an None-EN-Keyboard-Language?

Then that could be also your solution... perhaps you have to Change Keyboard-Lang to EN for enter Password.(?)

Here comes "Why" and also the solution for my problem one post above:

Thanks for the Keyboard tip again, it solved the puzzle.
Before, I was sure my PW has to be entered in my local Keyboard-language. Why? -> Because I changed already my PW for c: SSD, and it's the same as for d: hdd system favorite.

The problem was, I didn't notice that TC is so clever, to change my keyboard-lang in Windows to EN on changing password of system drive c:. TC do the Keyboard-lang change without even make a pop up or notice, so I missed it. Because TC makes the Keyboard-lang change on system drive c: automatically, I was so sure about the Password also for d:
But in the end, I typed all the time the wrong password at password-change for d: hdd, because I never changed Keyboard-lang manually to EN for changing d: hdd Password-

Now I did the following, and everything worked:
  • remove d: as system favorite
  • reboot PC
  • changed PW for d: HDD with "select device" and select the before mounted partition. On PW change, set Keyboard-lang to "EN", of course for both PW, the old and the new one.
  • changed PW for c: SSD, TC makes the Keyboard-lang change to "EN" automatically, changed the PW to the same PW as the new d: Password. So both drives have the same PW on EN-Keyboard.
  • mounted d: again
  • added d: as system favorite again
  • reboot PC and could use new password
  • all runs fine
I am not sure if reboot and remove system favorite is needed, but like this it worked.