This project has moved and is read-only. For the latest updates, please go here.

EFI booting HP laptop Help

Topics: Technical Issues
Apr 13, 2017 at 9:47 AM
I've trawled through the forums, there are some bits on this but not enough for me to piece together the resolution, so I was hoping for some guidance please.
HP Laptop
VC 1.2 beta2
Every time I boot, I need to use the rescue disc to point it to the EFI file.
(aside from that, all is ok, VC works fine)
I can not figure out how to get it to point to the VC EFI by default.
Or, that's accounted for in the this beta and I cant activate it.
In my BIOS, before the beta, I could chose secure boot on or off, it's currently off, but greyed out to turn it back on.
I don't have an option in the bios to choose an EFI file / boot order other than just the hard drive, USB, cd drive and so on.

So many hours into this and I'm stumped on how to progress.
Thank you.
Apr 13, 2017 at 9:54 AM
Apr 13, 2017 at 10:13 AM
Thank you Kavsrf,
I've seen those, I've the same problem as with some of the others on them - how do I get to that?
I'm at step A, they seem to be step D or E, its the steps B/C before then I can't do.

Once I'm into the BIOS, from there on, to try the above stuff, I cant find clear steps / dont know how to progress to make those changes.

There's clearly a gap in my knowledge to progress to what looks like a good published resolution.

I get the feeling this is a 30 second task, once one knows how to do it!
Apr 13, 2017 at 2:58 PM
Edited Apr 13, 2017 at 3:01 PM
browlry - 2017-01-31 wrote instruction step by step
Apr 18, 2017 at 6:54 PM
followed that, all seemed ok.
On restarting, it asked for the password, authorized it, then said success and then said
Start 0 290455552 len 98424212636

and goes no further.
My only option is the rescue disc.

Which depending on which EFI I choose, (Verycrypt,Boot,Microsoft,HP) just eventually gets me back to the password entry stage.
So VC seems to be succesful, after I cant get to any more stages.

I then tried my duplicate rescue disk and now I see some rescue options
Booting from this disc, no difference.
I restored the VC loader to boot menu, loader config OS header keys and loader binaries
Tried to boot from rescue disk, Password, Pim, success Start Len again then in yellow
Start \EFI|Microsoft\Boot\Bootmgfi.efi - not found

I think that file was on the rescue disk.
(I think I've seen it today, as when tried to boot from it, it moves me to the VC password step then it gets stuck again)

So, I'm guessing, in the above work to add in the VC efi, the Microsoft efi is lost/not being looked for?

How do I resolve that now I cant get into the PC to change the code?

(I've tried to decrypt it all from the rescue disc, after accepting the password, when it asks Decrypt? doesnt matter what I type (assuming it should be "y") it says Read error : Invalid parameter)

Thank you!!
Apr 18, 2017 at 7:28 PM
What disk do you use? It has to be prepared by OS encrypted. (keys are different).

\EFI|Microsoft\Boot\Bootmgfi.efi is Windows boot loader.

It has to be on EFI system partition (ESP) on HDD with OS.

To decrypt use 1.20b2 at least (1.19 has problem)
Apr 18, 2017 at 8:30 PM
I updated to 1.20b2 then created a disc.
with that version, I cant see the recovery options, just boot options.
The spare disc (I was 99% sure was the same process) will boot as recovery, (usb drive or efi file) but lots of errors on trying to decrypt.
0 (6826E218) Pc etc etc Success
Hidden Volume size 0
flags 0x1
read error invalid parameter
If try Ignore
Write error bad buffer size
read error again (hard drive)

then I stop pressing ignore!

Yes, the windows bootloader, is missing.
I cant tell if the file is gone or something just isnt pointing to it.
I can get to the point of passing the VC checks hurdle then I get the error that it cant find that file and things stop.

If I can fix thewin bootloader, I think it would work.
Apr 19, 2017 at 8:36 AM
Additions to this as I've been digging around
With no media plugged in F9, change boot order I can get to these files/options:
OS boot manager UEFI (then goes to VC password steps then the roadblock)
Notebook hard drive (then no bootable device connected, connect and press any key)(and doesn work)
Boot from EFI File
 System {PC iRoot (0x0) etc...
       EFI    (Lots of files)
       System volume info
       Boot     (contains no files)
 Microsoft    (Recovery, zero files)  (Boot - a whole range of languages, bootmgr.efi, memtest.efi, bootmgw.efi)
                              (trying either bootfile goes back to the VC password log in, which then doesn't progress past successful password entry)
 Boot       (contains bootx64.efi)
 HP         (system diags, bios update, bios)(not lead to it booting)
 Veracrypt    (DcsBoot.efi)
The missing file (or a copy of it) it seems is on the drive, the step going to it after VC is done is missing?
Apr 19, 2017 at 10:33 AM
Rescue disc version is 1.20b2
Apr 19, 2017 at 1:47 PM
Your situation is not ordinary. It is necessary to investigate it in details. It looks like Windows disk is corrupted.

There are several issues:
  1. You try decrypt procedure. it was failed.
  2. You made the modification and DcsBoot is executed but Windows was not loaded (it is strange)
At first you can connect hdd from the notebook to another computer to try mount OS encrypted.
(Mount->mount options->mount OS option)

details of the problem p2:
EFI voot process is simple.
There are several EFI variables in NVRAM.
Boot0001=HDD0 (ESP:\EFI\Boot\bootx64.efi)
Boot0002=Windows (ESP:\EFI\Microsoft\Boot\bootmgfw.efi)
BootDC5B=VeraCrypt (ESP:\EFI\VeraCrypt\DcsBoot.efi)

BootOrder selects order of modules to be executed. (if failed/not found it tries next)

HP creates another logic(non standard). It starts ESP:\EFI\Microsoft\Boot\bootmgfw.efi first always. To resolve the problem it is possible to
rename ESP:\EFI\Microsoft\Boot\bootmgfw.efi bootmgfw_ms.efi
copy DcsBoot.efi to ESP:\EFI\Microsoft\Boot\bootmgfw.efi
Instructs DcsBoot to execute ESP:\EFI\Microsoft\Boot\bootmgfw_ms.efi

ESP is EFI system partition (by default this is partition with special GUID type value in GPT)

How to check:
Could you list your rescue disk?
dir /s <rescue disk>:\
It has to contain EFI\VeraCrypt\svh_bak (file with OS keys. It is specific to OS encrypted!)

For deep analysis of OS hdd from rescue disk it is necessary to add WinPE with VeraCrypt and EFI shell to the rescue disk.
EFI shell - download to \EFI\shell\shell.exf
build WinPE based on Microsoft ADK - It is possible to execute VeraCrypt from the WinPE disk to mount OS and check contents.
Apr 19, 2017 at 2:32 PM
Ok, a lot there. (thank you though)
p1 - to get the hdd mounted into something else, I'll need to get some cables and connectors.
          (can be done, just takes a few days)
it seems I'm booting VC DcsBoot efi (then it passes that step)
then it asks for the Bootmgfw.

Rescue disc
winPE has been downloading all day, its nearly done.
Then I'll try that.

the steps - rename ESP, then copy DcsBoot - can/how do I do that without being able to mount the drive?
I have a feeling, that may fix it, as thats the file its asking for, I dont know how to carry out that step.
(is that what we need WinPe/VC/Efi shell for?)
Apr 19, 2017 at 2:58 PM
Ok - WinPe - theres a lot to learn there!
In the background, I created a Win10 recovery disc from windows, I've just been able to boot from it into Install windows (No) and Repair windows (Yes) and a number of options including a command prompt.
I'm having a dig about.
Apr 19, 2017 at 3:13 PM
Edited Apr 19, 2017 at 4:58 PM
Kind of progress.
With the command prompt, was able to follow the steps.
((rename ESP:\EFI\Microsoft\Boot\bootmgfw.efi bootmgfw_ms.efi
copy DcsBoot.efi to ESP:\EFI\Microsoft\Boot\bootmgfw.efi ))

On restarting:
Start 290..... len 984.....
Multiple execution of DcsBoot
Start EFI\Microsoft\Boot\bootmgfw_ms.efi - Invalid Parameter

(got to be getting close now!?)
Apr 19, 2017 at 3:23 PM
Restarted, command prompt, followed the other steps for Notepad DcsProp, mine looks exactly the same as the example one in Browlys original guide.
Apr 20, 2017 at 10:13 AM
Just a thought (may be dumb) now I can get to use a Win recovery disc, could I try to restore the boot section and then restore the VC loaders and stuff?
(rather than add back in the file)
Apr 26, 2017 at 8:51 AM
I've managed to get the drive de-crypted.
Even with Medicat recovery CD, (great for getting into the system - if anyone that is not overly skilled in these areas is reading this.(like me!)) I wasn't able to give it the missing file.
I got to where it wasn't always asking for it, sometimes it just went into a loop of once authorised, went back to asking for the VC password.
The files seemed to be in the recovery part of the drive, but I couldn't get them into the boot section or if I did, they didn't stay there for start up.
editing the EFI files I wasn't able to figure out.

So for completion sake -
In my recovery disc, I replaced these
With the newest ones I could find on the net

(KEEP YOUR ORIGINAL svh_bak file)
(as said above, that has your encryption details on it)

Once the drive was decrypted, I used the downloaded from Windows windows recovery disc to boot with,
went into repair
Did the repair option
It copied the right EFI files from the recovery section and then all started up ok.

I probably now wait until the next VC version comes out before attempting this process again.
HP seems to have things set in a way that just wants to be very awkward with the UEFI process, I'm not sure if I want to risk the time lost again fixing this if I do it again and the same error occurs.