This project has moved and is read-only. For the latest updates, please go here.

Decrypted partition inaccessible/corrupted

Topics: Technical Issues
Dec 12, 2016 at 1:28 PM

I'm having an issue with one of my decrypted VeraCrypt partitions not being accessible any more. I get an error saying that the partition has to be formatted before I can use it.

System: Windows 8.1, 64-bits (VeraCrypt 1.19)
Disks setup: 1 x SSD (2 partitions, including Windows), 1 x HDD (3 storage partitions)

So here's what happened. I have been using VeraCrypt's full system disk encryption for a long time. The three partitions on the secondary HDD were also encrypted using VeraCrypt.
Due to some Windows boot issues, I decided to decrypt the whole system, fix the issues and then encrypt everything again. Since I was unable to boot into Windows at all, I used the Rescue Disc to decrypt the system disk. After many hours the decrypting process was finished, and I used the same Rescue Disc to restore the original Windows bootloader.
To my surprise though, the laptop would still start up the VeraCrypt bootloader, even after taking the Rescue Disc out. Somewhere during this process I also restored the key header data.

After many reboots, I figured that the system might be trying to boot from the secondary HDD, which was still encrypted. I ran Windows CMD via the Windows recovery disc, and marked the SSD's Windows partition as active.
After that, I ran the decrypt process from the VeraCrypt Rescue Disc again. This time I physically took the secondary HDD out of the computer.

While the SSD was decrypting via the Rescue Disc, I decided to start decrypting the secondary HDD by hooking it up to another PC. I tried to access the three partitions on this HDD first to check if everything was OK. For some reason I could not mount the first partition of this HDD, as it gave me an error saying that either the password/PIM was incorrect or something else was wrong. I also tried to mount it using the "Mount without pre-boot authentication..." option; this did not work either. Surprisingly I was able to mount and access the files on the second and third partitions just fine. I decrypted the second and third partition. The first partition was still encrypted/inaccessible.

I went back to the first partition and chose Volume Tools... > Restore Volume Header..., which was successful.
Now I was able to mount the volume, but the files on it were still inaccessible. I'd get a Windows error saying that the partition should be formatted before I could use it. I figured that it might start working after I decrypt it using VeraCrypt. This time I used Volume Tools... > Permanently Decrypt... to decrypt it.

The partition finished decrypting just now, but unfortunately the partition itself is still inaccessible, and Windows is prompting me to format it before I can use it.
I believe that something must have gone wrong when I chose to restore the Windows bootloader or decrypt the system partition on the primary SSD. Maybe the Rescue Disc was accidentally performing all these actions on the secondary HDD. The reason I think this might have been the issue, is because it's only the first partition of the secondary HDD that is corrupted. The other two partitions on this HDD work fine.

Meanwhile the system disk and the two partitions on the secondary HDD have been decrypted successfully and Windows runs fine again.

Before I mess up even more, I'd like to ask help from here first. Let me know if you need more information.
Thank you for your time and help in advance.
Dec 12, 2016 at 7:20 PM
Clarification: EFI or MBR boot?

there is a bug in rescue disk of 1.19 if it is EFI. use 1.20b1
Dec 13, 2016 at 11:46 AM
Edited Dec 13, 2016 at 1:06 PM
Both disks are MBR.
The problem is that I have already decrypted everything, so the Rescue Disk is useless to me now. Is there a way to somehow "fix" the inaccessible partition, so I can access its contents?


Secondary HDD (with the three partitions) was not decrypted using the Rescue Disk, but using the VeraCrypt software on another PC.
Dec 15, 2016 at 6:41 PM
Shameless self-bump.
Would be great if someone knows how to fix the partition and get access to the files on it again. I'd prefer backing up the files that were on it, before formatting it as a last resort.