This project has moved and is read-only. For the latest updates, please go here.

Accessing a troubled TC external drive

Topics: Technical Issues, Users Discussion
Nov 19, 2016 at 6:58 PM
This is about a True Crypt (TC) problem, but perhaps someone here can advise.
Nearly five years, ago I created two TC partitions, one open, one hidden, on a 1TB Seagate external drive. At the time, I was using a desktop running Windows XP. Mounting the drives and file access worked fine.

When I changed my pc to a laptop running Win 7, I used software to transfer everything on the Win XP drives (C and D) to the laptop.

Some long time later, I tried accessing the Seagate's TC content by mounting on my Win 7 laptop. I couldn't find the same drive letter for mounting as on the XP so tried 'I' drive (for what that's worth). I then tried entering the original mounting passwords but the result was a MAJOR pc crash. The laptop closed down, went into a deep sulk for 3 days and wouldn't startup. On the 4th day, it miraculously allowed startup and reported recovering from a critical incident.

I'd like to be able to use the Seagate external drive with my laptop - which now has Win 10 OS. I don't need to save old content on the Seagate's TC partitions. Basically, I'd like to remove TC completely and just use the external drive normally - perhaps try Vera in future.

I am now concerned about even plugging the Seagate external drive in to my only laptop, let alone trying to mount. Can anyone advise on safe procedure to reformat (presumably) this external drive and remove the TC partitions?
Nov 23, 2016 at 11:12 PM
Edited Nov 23, 2016 at 11:12 PM
Sounds like some sort of a windows bug O.o or a hardware issue(more likely since your laptop didnt boot). I suggest plugging it in to another USB port and then simply formatting it(this will remove the TC encryption) :) Btw, when mounting it, you can check the checkbox 'TrueCrypt Mode'.