This project has moved and is read-only. For the latest updates, please go here.

Decryption of system with rescue disk stopped half way and does not react to Esc

Topics: Technical Issues
Nov 11, 2016 at 8:41 PM
Edited Nov 14, 2016 at 7:13 AM
OS: Windows Server 2016
HD: Samsung 840 Pro SSD
System drive encrypted with VeraCrypt 1.19


after installing the anniversary update, Windows would not boot any more from my encrypted system drive. After entering the password to VeraCrypt, I see the Windows start logo and the system freezes (no animated circles indicating any activity). I read that Windows update probably disabled the VeraCrypt driver and therefore Windows cannot access anything.
Therefore, I decided boot from my VeraCrypt rescue USB-stick and permanently decrypt the system drive. All worked well for a while, decrypting slowly at 2 MB/s. But then, decryption stopped half way (121794 MB remaining). I tried to defer decryption by pressing "Esc", but nothing happens. Now I am stuck and don't know what to do. From what I understood, when I reset the PC, VeraCrypt will not update the decryption state of the system and I cannot start another decryption.

Edit: 10 hours later the situation is unchanged.

Edit2: I forgot to mention that the cursor behind "Remaining: 121794 MB" is still blinking.

Edit3: I switched off the PC and I had to push the off switch for 4 seconds. This means VeraCryped crashed and froze the PC. I checked the SSD in a different computer and it turned out fine without any bad blocks.
Nov 12, 2016 at 10:09 AM
Since I don't see this working out for me, I would like to cut my losses.

1) Is it possible to restart the PC and tell VeraCrypt recovery to start decryption from 121794 MB? I assume that this would corrupt some sectors, but anything from 121793 MB onwards should be fine.

2) Can something similar be done by connecting the SSD to another PC and rescue/decrypt data from within Windows?

3) Would it make sense to create an image of my SSD and try out different things? But then I would have to switch off the PC. And I wouldn't know what "things" to try out.

Sorry, I am kind of desperate here. I didn't expect decryption to stop at some point. The SSD is healthy and so is my PC...
Nov 17, 2016 at 11:12 PM
  1. It should continue the decryption process where it left it.
  2. Yes, you can connect your SSD to another computer and access/decrypt it there. (It might say that the SSD is an OS one, so you'll need to "Mount options" -> "Mount ...with no pre-boot auth..."
  3. You can, but that would open another can of worms.
Nov 19, 2016 at 12:23 AM
Thanks for your reply!

1) In the meantime VeraCrypt crashed two more times. Every time I tried a new attempt to decrypt the disk, decryption started where it was deferred the last time. It did not start at the position of the crash. In the first occurrence, VeraCrypt crashed at "121794 MB remaining", and resumed decryption at the very beginning of the disk.

2) I should have tried that from the very beginning. Now, VeraCrypt GUI complains about system decryption not having finished and refuses to decrypt the disk. Apparently, once decryption was started with the rescue disk, it has to be finished that way.

3) Done! Turns out I don't like worms :-)
Nov 23, 2016 at 11:05 PM
Hey, thats great! Can you mark this thread as answered? :)
Nov 27, 2016 at 3:34 PM
Well, not that great. Point 3 was a rather sarcastic remark stating that I opened a can of worms, not that the can of worms solved anything.
I am at a point where I accept data loss. But this thread remains unresolved.