This project has moved and is read-only. For the latest updates, please go here.

Memory leak from veracrypt.exe

Topics: Technical Issues
Sep 26, 2016 at 8:16 PM
Okay all,

I know you have hacked this issue to death, but, there was a missing point. All previous questions relate to performance while copying to-from encrypted drives. I have an issue when the .sys and .exe are loaded but no drives are mounted. According to process explorer the private bytes and working set increase slowly until all 8GB are used this takes some hours but then the computer crashes and restarts. I have sat and watched this happen and I can't discover what is going on except it does not do this using version 1.16 but does using all later versions. I have an I3 with 8GB laptop and would like to benefit from the faster startup time using later versions. It also leaks memory when a container is loaded, but this is not necessary.

Please help someone as the posted cure will not work.
Sep 26, 2016 at 10:17 PM
Can you provide the link to posted solution you attempt to use to resolve your issue that you are having with your PC?
Sep 27, 2016 at 5:04 PM

I tried these two links, but I suspect I didn't understand the articles, and could not get the registry fix:

the links are:
and changing this ("SetSystemFileCacheSize off 512") did not work, but I don't think I was implementing it correctly, BTW if I exit the veracrypt.exe then restart it the count-up to all memory all-used restarts.

Oct 29, 2016 at 7:43 PM

I have just installed veracrypt 1.19 and can now confirm that the VeraCrypt.exe is still using gradually more and more memory both private bytes and working set. This is determined by watching process explorer until all 8GB is used up then the computer turns itself off.

I will have to go back to version 1.16 again.

This is quite tiresome, but I assume since this issue is not fixed I must be the only person in the whole world with, it and therefore it is my fault. funny how the old version works though isn’t it?

My pc otherwise performs well and has no other issues, I have worked with IT and other technologies all my adult life and consider myself competent, this is definitely due to how the encryption is now performed and I know there is nothing intrinsically wrong with the code as these late versions work on my other pc’s.

As I am typing this VeraCrypt.exe is using 160,000 K private and 177,000 K working.

Time to re-install 1.16.

this occurs even when no containers are attached, just the exe in memory.

Any help.