This project has moved. For the latest updates, please go here.

Win 10 can't start after encrypt system partition

Topics: Technical Issues
Aug 22, 2016 at 6:31 PM
Hello.

Today I installed stable VeraCrypt 1.18 and I encrypted my system partition. Test boot was ok - I typed password and system started very well. After this encrypt has been started. Encrypt ended successfully. Next I restarted my computer and I haven't seen screen where I could enter the password. My system wants to repair...

During the process of encrypt I created and verified rescue disc on my usb disc. After unzip I have folder called "EFI". It contains folders "Boot" and "VeraCrypt. How can I use it do decrypt my system partition? Can I decrypt disc on another computer?

I tried everything what I know - I restored BIOS setting to default, I manual selected my disc MX200 to start and always I have error.

My specs:
  • System: Windows 10 Pro
  • MOBO: MSI Z87-G43
  • Disc: Crucial MX200 500 GB
I done the same 1-2 years ago in True Crypt 7.1a on Windows 7 and everything was ok.

If you have any questions please ask me.
I would be very grateful for your help...
Developer
Aug 22, 2016 at 7:33 PM
Boot process of EFI and legacy BIOS is different. VeraCrypt 1.18 is the first release with EFI support. (and probably the only open source solution)

To start rescue disk:
  1. Create FAT32 USB flash disk
  2. Copy EFI folder to root of the disk
  3. Boot the disk (Try to press <F12>(the key depends of manufacture) to select boot disk or enter BIOS to change boot order.)
  4. Try to restore boot loader menu entry and reboot (before decrypt!)
Note: Disable Secure Boot option if it is enabled in BIOS.
Aug 22, 2016 at 8:36 PM
Edited Aug 22, 2016 at 8:55 PM
I done your instructions and now I see "An operating system wasn't found. Try disconnecting any drives that don't contain an operating system".

I tried copy EFI folder to flash disk and later copy Boot and VeraCrypt folders to root folder of flash disk - the same error.

After restored bios settings to default I see "VeraCrypt bootloader" but I can't use it to correct start

Image

Secure boot is disabled.

Why test boot goes ok and after enrypt I have a very big problem?
Developer
Aug 22, 2016 at 9:07 PM
Edited Aug 22, 2016 at 9:12 PM
Problem is new. I'm trying to clarify the situation.

It is necessary to boot from USB flash disk to decrypt.

Do not try restore procedure of Windows. It can't access encrypted drive.

Note: It looks like you have EFI shell built in BIOS. Boot it. Try to execute from the shell EFI\BOOT\bootx64.efi. It is necessary to select correct disk. (fs0: fs1: etc) To list contents use "ls" command.
Aug 23, 2016 at 7:56 AM
Yes, I have EFI shell biult in BIOS.

Image

I used it to boot my computer. I saw it:

Image

I can't type anything in this window. Only ctrl+alt+delete and restart.
Rescue disk is useless. In TrueCrypt always works very well. I have destroyed 400 GB data and I think the only solution for VeraCrypt is format C:

I tested the same on another computer (completely different specification) in my office and I have the same - partition C is encrypted, system doesn't start, rescue disk doesn't works too.

I trusted you, guys. Now I have two days wasted on unnecessary work...
Developer
Aug 23, 2016 at 9:20 AM
Edited Aug 23, 2016 at 9:34 AM
There is no USB disk among boot devices.

Probably USB boot is disabled in BIOS.

Note: VeraCrypt is community project. Your help and test results are very useful to improve project.
Aug 23, 2016 at 9:47 AM
USB boot is enabled - I can use Memtest or Windows install from USB flash disk without problems.

Thanks for answers but now I can only format partition C.

Result of my tests: DON'T encrypt system partition. Two computers are dead. Both windows 10.
Developer
Aug 23, 2016 at 10:02 AM
Edited Aug 23, 2016 at 10:05 AM
Is it possible to execute from EFI shell VeraCrypt rescue application?
  1. Boot EFI shell.
  2. Find USB disk among fsN: devices (to select use: fsN:<enter> and list "ls")
  3. From the device execute:
    EFI\Boot\bootx64.efi
e.g.
FS0:> EFI\Boot\bootx64.efi

Boot from USB loads EFI\Boot\bootx64.efi by default

It is also possible to execute VeraCrypt loader to enter password.
EFI\VeraCrypt\DcsBoot.efi

Note: EFI is rather new technology and not stable. Might be some incompatibles. I'm trying to understand
Aug 23, 2016 at 10:41 AM
It's my devices:

Image

But I can't select any devices:

Image

What can I do?
Developer
Aug 23, 2016 at 11:39 AM
You skip ":"
e.g.
fs4:
Aug 23, 2016 at 3:22 PM
Edited Aug 23, 2016 at 3:23 PM
Thank you very very much, I love you #nohomo :)))

By rescue disk I restored everything what I could, next I decrypted partition C, repaired windows bootloader and computer works very well...

Image

Image

Image

So, the most important things on MSI motherboards are:
  1. Boot EFI Shell (F11 and select "UEFI: Built-in EFI Shell")
  2. Find device (flash disk contains veracrypt rescue disk) on list
  3. Run EFI\Boot\bootx64.efi
  4. Restore everything :D
  5. Decrypt system partition
I also recommend unplugging unnecessary drives.

Thank you one more time, you restored my life :)
Developer
Aug 23, 2016 at 7:49 PM
Edited Aug 23, 2016 at 7:50 PM
Thank you for your tests :) and sorry for inconveniences. We are trying to do our best. The technology is new.

It is strange that VeraCrypt does not start normal and rescue does not boot from boot menu.

Note: To load VeraCrypt loader execute EFI\VeraCrypt\DcsBoot.efi from SATA drive If you continue experiments.