This project has moved and is read-only. For the latest updates, please go here.

Version 1.18 System Encryption pretest fails - makes Lenovo Miix310-10ICR unbootable

Topics: Technical Issues
Aug 19, 2016 at 9:06 AM
Edited Aug 19, 2016 at 10:04 AM
Hi all,

I used the newest version of VeraCrypt (v 1.18) and tried system encryption under EFI.

The system encryption pretest fails and is showing me a blue screen error "ACPI_BIOS ERROR".

Steps I tried to resolve the situation:
-) Manually choosing Windows Bootloader in Boot Menu. I can see the Veracrypt Bootloader and the Windows Bootloader, selecting the Windows Bootloader results in the same error.
-) Used Windows 10 USB Boot Medium. Selecting it from the Boot Menu results in the same error (Secure boot is disabled in bios).
-) Used Veracrypt Rescue Disk to remove the Veracrypt Bootloader, which worked (at least I'm not able to see the Veracrypt Bootloader in the Boot menu anymore), but now the Windows Boot Manager results in the same blue screen error "ACPI_BIOS ERROR".

Ongoing steps:
-) In the Bios there are two options:
Reset to setup mode (clear pk, disable secure boot and enter setup mode)
Restore factory keys (restore all secure boot database to factory default include pk, kek, db and dbx)
I have not yet understood what this options would do, so I will park this for now.

Any further ideas on how to proceed on this? I have the feeling that I'm not able to restore this device anyhow.

Update1: Moved an ongoing step to done.
Aug 19, 2016 at 10:27 AM
Edited Aug 19, 2016 at 10:31 AM
Have you performed a Google search on "ACPI_BIOS ERROR Lenovo"? You might want to review this error on Lenovo forums.

Once you are able to boot into Windows, you need to reinstall VeraCrypt using the updated Windows 1.18 or 1.18a installer which contains the Microsoft signed files for VeraCrypt drivers that were just released several hours ago for those users running the Windows 10 Anniversary edition.
Aug 19, 2016 at 1:27 PM
Edited Aug 19, 2016 at 1:29 PM
Thanks for your response and help, highly appreciated.

I now made a thorough search for the error message combined with lenovo devices. The BIOS has the most up to date version 1HCN31WW.

I found one user who has a similar issue, however I'm not able to follow his suggested resolution steps as I don't have access to an identical second device:

Further steps I tried:
-) Resetting BIOS to default settings
-) Created various Windows 10 USB boot devices, none of them seem to work. I can choose them in the boot menu, then the device restarts I see the Lenovo Logo and then again the acpi bios error message appears. I have the feeling that the usb stick cannot be started for whatever reason, so I will keep trying this with different setups.

Just for my understanding, is this a known issue in version 1.18 and would have been resolved if I would have waited and used version 1.18a?

Any further ideas what I could try? Thanks for any help!

(Just for info: I also created a topic in Lenovo forums regarding the ACPI BIOS error message)
Aug 19, 2016 at 2:33 PM
The issue is new.

Could you write details about your configuration? computer model?
Aug 19, 2016 at 3:00 PM
Edited Aug 19, 2016 at 8:26 PM
Computer model is: Lenovo Miix 310-10ICR (
I had Windows 10 Home 64bit installed with the installed anniversary update and all available windows updates till yesterday.
Used Veracrypt version: 1.18
BIOS version: 1HCN31WW (also up to date)

I used the system encryption with all the standard settings (AES and SHA) and also have the created veracrypt rescue disc available on an usb device (which works fine). The partition is not yet encrypted as Veracrypt told me that it will restart to do the pretest and then the problems started. Removing the Veracrypt bootloader via the Rescue disk sadly did not resolve the issue.

Any other information I could give you to dive into this error? :-)

Just successfully booted with a gparted usb drive

So I can provide additional information about the systems drive setup:

I'm getting crazy creating a working windows installation medium on a usb device, it looks like everything else as a boot medium is working except this. (Using rufus to get the iso image on the usb device)
Aug 20, 2016 at 12:50 PM
Edited Aug 20, 2016 at 12:57 PM
Thank you for your tests. You use VeraCrypt with tablet. Processor of the tablet is Atom. The CPU does not have some extensions. It can cause problem. I'll prepare WinPE rescue disk for you to recover.

One more: Could you check version of your Windows? I suspect it is Windows 10 IA32.(not x64)
Current version of VeraCrypt UEFI system encryption works with x64 version only.
Aug 20, 2016 at 5:22 PM
Edited Aug 20, 2016 at 5:23 PM
Since your disk is not encrypted and since you are able to boot on gparted, the quickest solution is to boot on a Linux live USB drive and then mount the Windows NTFS partition and then remove the file "Windows\System32\Drivers\veracrypt.sys". After that reboot the tablet and you should not have any issue since VeraCrypt will no longer load at boot.

As a Linux USB, you can use Ubuntu.

Does the BSOD is solved with this?
Aug 20, 2016 at 10:25 PM
Edited Aug 20, 2016 at 10:37 PM
Thanks for your help.

It is (or was :-) ) in fact a Windows x64 and not an IA32.

I booted with gparted and deleted the veracrypt.sys as mentioned. After a reboot the blue screen is still there (so I booted again with gparted and double checked that the file was removed... and yes it is not there anymore). This doesn't make any sense to me anymore..

Any more ideas on this?

Edit: Just for info I used VeraCrypt Version 1.17 a long time on this device without any problems, of course without system encryption but with full disk encryption on a additionally inserted micro sd card.