This project has moved. For the latest updates, please go here.

Unable to decrypt hidden volume

Topics: Technical Issues, Users Discussion
Jun 30, 2016 at 3:26 PM
Hello,

I copied a hidden volume container file to another computer. I can open the non-hidden portion of this container file on the new computer, but not the hidden part. Both computers are Windows 7. When transferring the file I used an external USB hard drive to transfer out of the old computer and then transfer into the new computer.

Also, the password for the hidden volume uses an apostrophe created in Microsoft Word 2003. This is not the same apostrophe if you simply type the password directly into Veracrypt using your standard keyboard. I wrote about that here:

https://veracrypt.codeplex.com/discussions/651695

As far as I understand it - I should be able to copy an encrypted file container and still have access to the data inside. Is the same true for hidden volumes?

Since I am able to open/decrypt the non-hidden part of the copied container file which is on the new computer - I feel I still have an issue with the character set. I can still open the hidden volume on the old computer - I must copy the password directly out of the Microsoft Word document (where I store the password) and then paste into Veracrypt while mounting (so that the correct apostrophe will be entered into Veracrypt).

I'm not sure what I should do next. Re-copy? Is there a way to check a character set? For that matter are there any other characters I should avoid for passwords? Typically, I FIRST write the password in Microsoft Word and then copy that password while creating a volume. I should discontinue that method (saving passwords in MS Word Docs) - but that is what I have been doing.


mantr
Jun 30, 2016 at 5:58 PM
Hell mantr,

Your problem appears to be with the apostrophe character that you are using, because I've used hidden volumes in the past without a problem.

When you hit apostrophe on the keyboard, it generates a straight down character: '
MS-Word can additionally convert this into apostrophe's that tilt to the right or to the left. These special characters are not on your keyboard, but you can enter them by using the "Character Map" utility or directly via special keyboard ALT codes: http://www.dummies.com/how-to/content/how-to-insert-special-characters-with-windows-7-ch.html

The article at https://www.wintertree-software.com/support/ssce/java/curlyapostrophe.html suggests that the code for Word's curly apostrophe is ALT+0146 (press and hold ALT key, then enter 0146 on the numeric keyboard [num-lock needs to be enabled for this]) and this seems to work for me: ’

Try to enter the character this way and see, if this works. If not, then very likely you are using a different character. In general I would avoid characters that you don't know, how to enter manually. And I don't even want to get into the issue with storing your passwords unencrypted in a Word file.

Since you still have a access to your old computer, change the password and used something other than ’ If you are still using Word (I hope not), also avoid double quotes, since Word manipulates those as well.
Jun 30, 2016 at 7:03 PM
The Word files are password protected - not sure that also means the Word documents are also encrypted. This technique dates to about the year 2000. Yes, I should abandon this procedure - that is my intention as soon as I find another method that will work for me. Right now these Word documents are encrypted using VeraCrypt - but this topic is a separate discussion.

As for the apostrophe I understand the basic difference already. That was a problem I solved (with a workaround) in February of 2016 and then posted here about it - just in case someone else ran into a similar scenario. I don't have any problem with the apostrophe since I copy & paste the character directly from the Word document using ctrl-c and ctrl-v. This works with Verycrypt and I have done this for months now. And, I have no problem opening the hidden container file on the original computer. I just can't open the copied hidden container on the new computer for some reason.

Just for grins - I did try the alt-0146 - the apostrophe looks identical to the one I copy from MS Word. I tried alt-0180 as well. Neither of these alternate methods worked. However, I don't have a problem simply copying the special character from Word - and, as I've said, have been doing that for months now - without a problem.

All I did was copy the container file from one computer to another.

The Word document containing the password with special characters is on my network drive - both the old and new computer access the same Word doc. Both computers have same version of Microsoft Word 2003.

Moving forward it would be good to know what other characters to beware of. I never would have used special characters if it weren't for security - but it was only after I ran into this hiccup that I realized the issue/hassle. Assuming character sets really are the issue for this particular problem. Perhaps copying the original container file as I have done it changed something - changed the container file. I don't know. It might be good to find a way to check the two files themselves for differences. I can see that the date of the copied file isn't he same as the original file (as seen in Windows Explorer).

What is confusing is that I can open the non-hidden container.

hmmm...
Jul 5, 2016 at 11:20 PM
This is interesting. As mentioned above I used an external USB to transfer the hidden container file - from the old computer to the new computer. I noticed that the original computer can open the hidden container file from the external USB (although permissions needed to be changed so that they were not read only), but the new computer cannot open the same hidden container file from the external USB drive. I'm not sure what to make of that.
Jul 12, 2016 at 11:31 PM
I finally got this working - I can mount the encrypted container file on the new computer. I changed the password of the container file that had been copied to my external USB drive using the old computer (only the old computer could mount this file). I changed one character of the password replacing the ’ (not ') with a standard letter from the alphabet. That did the trick. Although, I still do not know why the new computer could not supply the correct version of the ’ - but, I'll try to be careful not to make this mistake again (typing a password into Word first - which may result in Word altering the character to something difficult to reproduce using a keyboard).