This project has moved and is read-only. For the latest updates, please go here.

Mount encrypted drive on another PC

Topics: Technical Issues, Users Discussion
Apr 12, 2016 at 2:33 PM
I encrypted an entire OS drive and the system does boot and enter Windows after I enter the VC password. I have no PIM so I just hit enter when it requests the PIM. I am doing this as a test to better understand how to mount an entire drive if there is an issue with booting.

I removed the encrypted drive and connected it to another PC via a USB cable. I run VC and choose Select Device and choose the encrypted HD. I choose a drive letter and select Mount. I enter the password and after a few seconds get an Operation Failed message.

Is it possible to mount a drive in this way and what am I doing wrong? Thanks.
Apr 12, 2016 at 3:02 PM
When you connect the OS drive as a secondary drive on another PC, you need to use the Mount Volume option button and enable the option "Mount partition using system encryption without pre-boot authentication".
Apr 12, 2016 at 3:12 PM
I'm not able to do this because I encrypted the entire drive so I'm unable to select a particular partition on the drive. I can only choose the entire drive. I apologize if I am missing something though and appreciate the help.
Apr 12, 2016 at 3:27 PM
Edited Apr 12, 2016 at 3:33 PM
Do you get the same error message "Operation Failed" when using the procedures I posted for an entire system drive encryption?

Your procedures do not make sense:
  1. I removed the encrypted drive and connected it to another PC via a USB cable.
  2. I run VC
  3. choose Select Device
  4. choose the encrypted HD <------ This step does not make sense. EDIT: Okay, you meant select the encrypted device. I read this statement as you were choosing an option to encrypt the device. :-) My misunderstanding.
  5. I choose a drive letter
  6. select Mount <----- This is the step you need to also click on the Mount Options button to enable the option I posted.
  7. enter the password (leave PIM empty).
Apr 12, 2016 at 3:39 PM
When doing this I get a No Partition Selected error.
Apr 12, 2016 at 3:57 PM
Edited Apr 12, 2016 at 3:57 PM
The developer will need to review this issue since this may have been inherited from TrueCrypt or is a bug in VeraCrypt.

Please provide additional details of your original and secondary PCs OS version including 32/64 bit and which version of VeraCrypt you are using on both PCs. Is VeraCrypt installed or are you attempting to use portable mode?
Apr 12, 2016 at 4:07 PM
Both HDs have Windows 7 Pro 64 bit. I am using VC version 1.17. I have not installed VC on the PC where I am trying to mount the encrypted drive so it is being run in portable mode. Should I install it?
Apr 12, 2016 at 4:34 PM
I do not know if installing VeraCrypt on the other PC will help. You can try it since the installation is very quick.
Apr 12, 2016 at 5:21 PM
VC was installed but the same issue was realized.
Apr 12, 2016 at 8:18 PM
For the system drive, it may be necessary to make it the primary drive and then possibly use the rescue disk that you created for that system drive. But doing this on another machine may give you issues if the hardware is not close enough (underlying hardware that Windows is installed upon).