This project has moved. For the latest updates, please go here.

Problem with OSXFUSE 3.2.0 (Developers' Preview)

Topics: Technical Issues
Mar 11, 2016 at 8:25 AM
Edited Mar 11, 2016 at 8:36 AM
I was getting serious problems with an older version of OSXFUSE, unrelated to VeraCrypt, so I updated to the latest stable version, which is version 2.8.3. However, that version has a serious bug (whereby external hard drives do not get unmounted properly when disconnected or ejected), so I installed version 3.2.0 instead, which is tagged as "Developers' preview", but seems to work well when it comes to mounting/unmounting NTFS drives.

Sadly when I launch VeraCrypt I am now getting the following error message:
VeraCrypt requires OSXFUSE 2.3 or later with MacFUSE compatibility layer installed. 
shortly after entering the password. And I am unable to proceed further.

Of course I did enable the MacFUSE compatibility layer.

So I'm between a rock and a hard place: with OSXFUSE 2.8.3 (the 'stable' version), reading NTFS HDD is a mess, and with the latest version (unstable) OSXFUSE 3.2.0, I cannot use VeraCrypt. I'm very reluctant to going back to an older version of OSXFUSE (older than 2.8.3) because I've had problems with that too (different problems from improper unmounting)!

Any suggestions? Thanks!


References:
The OSXFUSE Bug: https://github.com/osxfuse/osxfuse/issues/119
The OSXFUSE releases: https://sourceforge.net/p/osxfuse/activity/
Coordinator
Mar 11, 2016 at 8:42 AM
Hi,

Another user has already reported this in the issues tracker (https://veracrypt.codeplex.com/workitem/394).

As you can read in the link above, a new version has been published (1.18-BETA) that solves this. You can get it from here (its PGP signature is here)
Mar 11, 2016 at 10:05 AM
Roger that! Thank you Idrassi. Problem solved!

P.S. Sorry about reporting the issue a second time -- I hadn't seen the previous post.