This project has moved and is read-only. For the latest updates, please go here.

After update to 1.17: "device does not exist" when trying to share

Topics: Technical Issues
Feb 23, 2016 at 6:00 PM
Edited Feb 23, 2016 at 6:02 PM
Hi,

with TC and VC 1.15 I always mounted one container as drive y:, then I shared it by command line: net share "y"=Y:\ /GRANT:HomeUsers,CHANGE

I can still mount as y:, all working fine on my computer, but when I try to share it, I get an error 2116 (device or file does not exist). Same when I try it manually in Windows Explorer.

But: When I mount the container as drive "z:", I can share it without problems.

I already deleted old entries in the registry but that did not help. Any ideas?

Windows 7 64bit
Feb 23, 2016 at 6:50 PM
Have you tried the following?

First upgrade to latest version. I include this statement for the benefit of other users reading this thread.

With the all volumes dismounted, perform the following.

Using a modified version of Idrassi's instructions:
Check the registry key "HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices" using regedit. Scroll down and you'll find entries starting with "\DosDevices\" which indicate the drive letters that are taken by the system. Before mounting any volume, double click on each one and remove the ones contains the name "VeraCrypt" and "TrueCrypt".
Also, there are other entries whose name start with "#{" and "\??\Volume{": double click on each one of them and remove the ones whose data value contains the name "VeraCrypt" and "TrueCrypt".
.
Reboot PC.
Feb 23, 2016 at 8:09 PM
That procedure fixed it. Before there was no "y" entry at \DosDevices.

Thanks for the fast help.