This project has moved and is read-only. For the latest updates, please go here.

Same letter for non-system partition

Topics: Feature Requests, Technical Issues
Jan 20, 2016 at 8:02 AM
I have encrypted partition with letter (e.g.) X.

When I mount this partition with VeraCrypt, it is assigned a different letter (e.g.) Y.

So, encrypted partition occupies two letters.
Is it designed this way or am I doing something wrong?
I would expect that encrypted partition would use the same letter after encryption.
Jan 20, 2016 at 4:25 PM
Did you remove the drive letter X from Windows Disk Management for an existing partition after you encrypted the partition?

A common problem when people encrypt an existing partition is that Windows has already assigned a drive letter to the partition or the user has defined the drive letter to be used for that partition/device. After you encrypt the partition and with the VeraCrypt volume unmounted, Windows still has the drive letter assigned to that RAW partition which you need to remove using Windows Disk Management.

Another issue is if you used version 1.15 in the past which has this problem.

There may be something in the registry causing the issue.

First upgrade to latest version 1.16 or higher.

With the all volumes dismounted, perform the following.

Using a modified version of Idrassi's instructions:
Check the registry key "HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices" using regedit. Scroll down and you'll find entries starting with "\DosDevices\" which indicate the drive letters that are taken by the system. Before mounting any volume, double click on each one and remove the ones contains the name "VeraCrypt" and "TrueCrypt".
Also, there are other entries whose name start with "#{" and "\??\Volume{": double click on each one of them and remove the ones whose data value contains the name "VeraCrypt" and "TrueCrypt".
Reboot PC.

Kind Regards.