This project has moved. For the latest updates, please go here.

Unmount Issue

Topics: Technical Issues
Jan 10, 2016 at 8:12 AM
Edited Jan 10, 2016 at 8:24 AM
Hi,

I mounted a drive from an external hard disk after mounting successfully I can't open the drive so I had to mount it again to the same drive (drive G:). When I'm done I tried to unmount that drive but veracrypt won't unmount. Link to screenshot Please see the external link to the screenshot.

I tried several times putting back the external hard disk clicking the Dismount All button but that drive G: remains there. How can I unmount that drive?

thanks
Jan 10, 2016 at 2:56 PM
First upgrade to latest version 1.16 or higher.

With the all volumes dismounted, perform the following.

Using a modified version of Idrassi's instructions:
Check the registry key "HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices" using regedit. Scroll down and you'll find entries starting with "\DosDevices\" which indicate the drive letters that are taken by the system. Before mounting any volume, double click on each one and remove the ones contains the name "VeraCrypt" and "TrueCrypt".
Also, there are other entries whose name start with "#{" and "\??\Volume{": double click on each one of them and remove the ones whose data value contains the name "VeraCrypt" and "TrueCrypt".
.
Reboot PC.

Kind Regards.