This project has moved and is read-only. For the latest updates, please go here.

Just upgraded to 1.16 (64 bit) now bat file doesn't work

Topics: Technical Issues
Dec 4, 2015 at 9:27 PM
When I first setup Veracrypt (converted a Truecrypt container) I set Veracrypt to auto start at boot up with the following parameters in a batch file...

start "" "C:\Program files\VeraCrypt\VeraCrypt.exe" /v /mremovable "c:\program files\Veracrypt\cdswin-Rm" /lz /b /a /q background

The above has worked for a very long time, until today. Now, after upgrading to 1.16, the batch file doesn't work, giving the error message "Error while Parsing Command Line".

What happened and how do I fix this?
Dec 4, 2015 at 9:36 PM
Dec 4, 2015 at 10:28 PM

I saw those answers but it didn't fix my issue.
I tried putting a space between /l and z but that didn't solve the problem. That's why I removed the space back out as you can see in my post above. I still get the same error whether there is or isn't a space between /l and z. That's why I started the new thread thinking that there must be something different happening because of this newer upgrade.
Dec 4, 2015 at 11:09 PM
put space between /m and removable.
In the links above, it is clearly stated that you have to put space between a switch and its parameter...not only /l.
Dec 4, 2015 at 11:28 PM
Thanks for your help, but I tried that, but didn't work, an experiment, I deleted /mremovable form the batch file switches and now it is working again.
I don't understand why but at least it working.
Is there a reason I used to have to have the /mremovable switch and now I don't? Is there something I'm missing by not having this switch in the batch file?
Dec 6, 2015 at 4:19 PM
Did you add the switch back as shown below? You post above incorrectly has them together.

/m removable
Dec 6, 2015 at 4:34 PM
No I did not re-add the switch. As I mentioned, I tried it with a space between the /m and removable but still got the error, then I did an experiment where I just completely removed the switch and now the batch file is working properly without the switch added.
Did the upgrade change some how so that this switch is no longer needed or is there something I'm missing by not having the switch (/m removable) in the batch file?
Thanks for the help but I'm still confused.
Dec 6, 2015 at 4:38 PM
Are you mounting a disk or CD/DVD disk?
Dec 6, 2015 at 5:33 PM
Edited Dec 7, 2015 at 2:51 PM
I'm mounting a disk.
The reason I set it up this way was when I converted from Truecrypt to Veracrypt back months ago, for some reason I was having problems getting the disk to mount. A suggestion was made that on the default mount option I should create the disk as a removable media. This worked so it has been that way since day one...and thus the added switch.
My guess is, since I haven't upgraded Veracrypt since I first installed it, the upgrade I just did must have changed something in the program itself that now conflicts with the switch.
Any ideas?