This project has moved and is read-only. For the latest updates, please go here.

System Favourite A:\ drive has to be re-mounted manually on each startup

Topics: Technical Issues
Nov 15, 2015 at 10:37 AM
Hello everyone,

I had 3 out of 5 partitions encrypted on my Windows 8.1 system, and recently decided to encrypt a 4th one too.
After encrypting and mounting it, I added it to the System Favourites too, so it would auto-mount during boot.

Unfortunately, when I restart my PC the drive is not auto-mounted and I have to mount it manually each time I boot the PC. I assigned the letter A:\ via System Favourites.
Image

When I try to add it to the System Favourites again each time, it's already present.
Image

Any suggestions?

Thank you very much in advance.
Nov 15, 2015 at 3:27 PM
Edited Nov 15, 2015 at 5:27 PM
Just to eliminate the obvious, is the password and PIM the same as the password and PIM for system encryption?

Do you use keyfiles to mount the volume?

What version of VeraCrypt are you using on your PC?
Nov 16, 2015 at 8:31 PM
Hi,

Thanks for your reply.
Yes, I'm using the same password, and didn't touch PIM. (So I assume it's the default one)
And no keyfiles are used.

I used to use an older version, but I did the encryption of the A:\ partition after updating to version 1.16, 64bit.
Nov 16, 2015 at 8:59 PM
Did you ever have version 1.15 installed? The 1.15 version would create duplicate mount points with different drive letters. This could be why the "A" mount point in the registry will not work properly.
Nov 16, 2015 at 9:05 PM
Not that I can recall. I'm pretty sure that I skipped one or two versions when updating to 1.16.
Although, maybe I'm confused with my main system, let me check the release dates. (I recently reinstalled Windows on this system)
According to the release dates, I probably used 1.13 or 1.14 before updating directly to 1.16.

I don't think downgrading would be an option, would it?
Nov 16, 2015 at 9:30 PM
To avoid possible issues, let us manually remove the drive definitions from both VeraCrypt and the registry. Then add them back to see if the problem persists.

Remove the "A" from the System Favorites.

With the all volumes dismounted, perform the following.

Using a modified version of Idrassi's instructions:
Check the registry key "HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices" using regedit. Scroll down and you'll find entries starting with "\DosDevices\" which indicate the drive letters that are taken by the system. Before mounting any volume, double click on each one and remove the ones contains the name "VeraCrypt" and "TrueCrypt".
Also, there are other entries whose name start with "#{" and "\??\Volume{": double click on each one of them and remove the ones whose data value contains the name "VeraCrypt" and "TrueCrypt".
.
Reboot PC.

Add the "A" back to System Favorites and reboot PC to see if the problem is resolved.
Nov 17, 2015 at 9:39 PM
Hello again,

Thanks for the suggestion.
Unfortunately it did not fix the issue. This is what I have done:
  1. Unmounted ALL volumes (except C:)
  2. Remove all removable "TrueCrypt" and "VeraCrypt" Registry values, as you wrote
  3. Restarted PC
  4. Added A:\ to System Favourites
  5. Restarted PC
  6. A:\ was unmounted again (, but still in the "System Favourites" list)
Nov 17, 2015 at 10:03 PM
Does this volume mount in System Favorites if you use a different drive letter other than letter A when you boot your PC?
Nov 18, 2015 at 2:02 PM
I tried using W:\ as the drive letter this time.
This did indeed fix the issue, so it seems to be an issue with the A:\ drive (again).

Can this be added to the bug list? Because all of my software is installed on A:\, and if I change the drive letter, everything will be messed up.
Or is there any other way I can fix this (temporarily)?

Thanks for your help again.
Nov 18, 2015 at 6:14 PM
Edited Nov 19, 2015 at 5:08 AM
Before considering this a bug on Windows 8.1, let us try removing all currently non present USB Storage Devices, Disks, CDROMs, Floppies, Storage Volumes and WPD devices from the device tree. Furthermore it removes orphaned registry items related to these device types.

I request you use DriveCleanup version 0.9.0 and not the latest version due the latest version does not wipe existing devices from the registry.

http://www.uwe-sieber.de/drivetools_e.html

http://www.uwe-sieber.de/files/drivecleanup090.zip
.
  1. Download the DriveCleanup software.
  2. Create a directory and unzip the files into the directory.
  3. Start a command line prompt as Administrator.
  4. Change into the directory and if you are using 64-bit Windows OS, change into x64 subdirectory.
  5. Dismount all volumes.
To see what the utility will remove from the registry:

drivecleanup -T

To remove items the registry:

drivecleanup

Reboot PC after running utility.

Any USB that was not currently connected to your PC will be install again by Windows and you may have to manually reassign the drive letters in Windows Disk Management if you had certain drive letters for an external hard drive or thumbdrives.

I have performed this numerous times on my Windows 7 Pro 64-bit system to remove all registry entries including valid devices due to tests with file containers.
Nov 19, 2015 at 8:33 AM
Edited Nov 19, 2015 at 8:35 AM
I dismounted all the VeraCrypt drives and ran both commands via an elevated command prompt.
After the cleanup I restarted my PC, but unfortunately the A:\ drive was not auto-mounted. (But it was still present in the "System Favourites" list, as before)
Nov 24, 2015 at 8:06 PM
Hi again,

Is there anything else I can try to solve this issue, or can we actually consider this a bug now?

Thank you very much for your help so far.
Nov 24, 2015 at 10:09 PM
Hello,

I will not be able to test your scenario with my system.

The only other idea that may prove this is an issue with using both A & B drive letters which Windows treats a little differently as they were reserved for floppy drives is to remove the B volume and see if the A volume is able to mount during system boot-up.

Kind Regards.
Nov 25, 2015 at 6:39 PM
Hi again,

What exactly do you mean with "remove the B:\ volume"? Just remove it from the System Favourites and then try again?
Nov 25, 2015 at 6:43 PM
Edited Nov 25, 2015 at 7:02 PM
Hello,

Correct, just remove the B drive from the System Favorites and leave the A drive in System Favorites. Reboot PC to see if A will mount.

It would be great if another forum member running Windows 8.1 with system encryption could test mounting both A & B drives at the same time using System Favorites.

Kind Regards.
Nov 25, 2015 at 9:21 PM
Hi,

I just tried this; unmounted B:\ and removed it from the System Favourites. I then mounted A:\ and added it to the System Favourites.
Then I restarted my PC. Unfortunately A:\ did not auto-mount, but was, as always, still present in the System Favourites list.

Would it technically be possible to test this in a virtual machine?
I guess there's no hope for this bug to be fixed, until someone is found who can also reproduce this?
Dec 3, 2015 at 11:54 PM
Hi Miniwinkel,

Microsoft officially discourage using A: and B: drive letter with things other than removable media. They don't give any explanation about this but maybe there are cases where Windows kernel will have issues if a fixed drive is present on A: or B:.

Can you please try checking "Mount selected volume as removable media" for the A: favorite and see if it solves your issue?

Also, did you check Windows Event Viewer to see if there is any error or warning message related to this in the time period where your system is starting?

If the removal option doesn't solve the problem, then one possible technical explanation is that the A: drive letter is not ready to accept volumes when the system favorite mounting occur...maybe making VeraCrypt try again after some time can solve the issue.

Meanwhile, I will try to setup a Windows 8.1 VM to check if I can reproduce this.
Dec 5, 2015 at 9:35 AM
Edited Dec 6, 2015 at 9:54 AM
Hello Idrassi,

Thank you for your reply.
I tried checking "Mount selected volume as removable media", but that didn't mount the A:\ partition during boot either.

On a side-note: the same setup does work on my Windows 7 machine. (Having both A:\ and B:\ auto-mount during boot) Not sure if that helps.

How exactly do I use the Windows Event Viewer to find problems during boot?

EDIT: Nevermind, this exact same issue seems to happen on my Windows 7 machine. My bad.
Dec 15, 2015 at 3:56 PM
Hi again,

Any news on this?
Dec 16, 2015 at 1:12 AM
Hi,

I was able to reproduce the issue. I didn't post anything because the investigation is ongoing and the issue is very strange: it looks like the driver is not receiving the the correct drive letter from the mounting service when the A: is chosen.

Anyway, I will give an update as soon as I have found an explanation.
Dec 16, 2015 at 9:15 AM
Hello Idrassi,

I see. Apologies then, I thought you might have forgotten about this.
Thanks for your help and testing again.
Dec 16, 2015 at 10:49 PM
Hi,

Finally the issue was really simple but I was looking at the wrong place...
I have implemented a fix and I uploaded an installer for 1.17-BETA that includes the fix. You can get it from https://sourceforge.net/projects/veracrypt/files/VeraCrypt%20Nightly%20Builds/

Thank you for reporting this.
Marked as answer by Miniwinkel on 12/17/2015 at 2:35 AM
Dec 17, 2015 at 10:35 AM
Hello again,

Thank you so much, Idrassi, version 1.17-BETA seems to have solved the issue for me.
It was one hell of an annoying issue, so I'm glad it's (relatively easily) solved now.

Thanks again, I appreciate your time.
Consider this solved.