This project has moved and is read-only. For the latest updates, please go here.

Curious error: MMP:11

Topics: Technical Issues
Nov 13, 2015 at 1:08 AM
I'm afraid I'm stuck, and might need a bit of help :)

Somehow I'm unable to encrypt the system partition in Windows 7 on my laptop. That in itself is strange, because the same machine in the past has been running with the system partition encrypted in Truecrypt.
The layout of the system is:

Disk 0: 2 x 1Tb HDD in a striped array, seen by Windows 7 as 1 disk with 1 partition
Disk 1: 2 x 250Gb SSD in a mirror array, seen by Windows 7 as 1 disk with 3 partitions (100Mb system reserved, 150Gb system, 100Gb data partition).

The partition on Disk 0 (2Tb) is encrypted in Veracrypt (cascade AES/Twofish/Serpent). The same goes for partition 3 on Disk 1 (100Gb).
Partition 2 on Disk 1 (150Gb system) is, according to Windows 7, active & boot.

When I try to encrypt the system partition everything seems to go fine, until the moment the test routine restarts the system and verifies the password (no PIM has been specified).
The password verification is reported to be OK, but then a new line appears reading:

Error: MMP:11

This happens, no matter which encryption method I use (AES, or some form of cascade).
I can press Enter to reboot (as normal) into Windows 7, and the original boot loader is restored ... leaving me puzzled as I've no idea what's going wrong.

Can anyone help out, please? Thanks in advance!
Nov 13, 2015 at 7:52 PM

This is the fist such report.
Do you see the messaging "booting..." after the OK or not?
  • If booting message is displayed and then you have the error message, this would mean that the error is not within VeraCrypt context but either from Windows loader or from the BIOS low level routines.
  • If booting message is not displayed, then an error must have occurred when VeraCrypt tried to launch Windows loader. MMP in the message "Error:MMP:11" could mean Memory Protection: this would suggest that there is not enough memory to execute the loader.
Also, can disable or disconnect Disk 0 and try again? This will free some BIOS memory and this could help.
Also, did you connect any new hardware since the last time you used TrueCrypt? for example an extension card or a new graphic card.

For now, this is what I can think of. Depending on your feedback, we may explore other ideas.
Nov 14, 2015 at 1:21 PM
Edited Nov 14, 2015 at 1:23 PM

Thanks for your reply, much appreciated.

The message "Error: MMP:11" immediately follows the message "Verification OK"; there is no boot message.
The system will boot normally after I press Enter (I'm not 100% sure, but if my memory serves me correctly the system will boot by itself after some time).

I never gave any thought to the possibility that memory could be a problem as the system has a modest 32 Gb memory available :)
But if only some BIOS memory is available and not the 32 Gb main memory, I suppose there might be a problem.

The system is the same as when I set it up with a TrueCrypt encrypted system partition, a long time ago. No new hardware has been added.
Also, the pass-phrase used is the same; and although it's quite lengthy (40-odd characters) I think it's unlikely that could cause a problem.

I'll do some more tests, including your suggestion to disconnect Disk 0, and will update this thread with the results.
Nov 14, 2015 at 4:50 PM
Quick update: not good news.

Nothing I've tried seems to have any impact at all; the result is always the same:

Verification... OK
Error: MMP:11

after which I can boot into Windows 7 (by hitting any key).
Then, the VeraCrypt window comes up offering the possibility to try again, or restore the original boot loader. I choose the latter, and everything is back to normal.

I've tried with everything not needed disconnected from the computer; also, Disk 0 disconnected (by physically removing one of the HDDs that are part of the RAID array).
I tried a shorter password (20 characters) ... same result.

I seem to run out of options, but there's one thing I might try: physically removing both HDDs to eliminate Disk 0 completely (removing one of the HDDs means that Disk 0 is still visible in Disk Management, even though the array is not functioning).
However, removing both HDDs is a bit of a problem because it means virtually taking apart the complete laptop. I can give that a try on Monday with the help of my computer dealer ... unless you have a better idea, that is!
Nov 18, 2015 at 12:50 AM
Update: tried again, after physically stripping all hardware from the computer that was not needed for the test (including both HDDs).

The result is exactly the same as before: the password is OK, but then the error MMP:11 comes up again.

I'm not sure where to go from here: it appears this is either a VeraCrypt problem, or something wrong with the mainboard or the BIOS (I checked all settings of the BIOS, but don't see anything strange there).
I'll request detailed mainboard and BIOS info from the manufacturer of the laptop (Clevo), but if past experiences are anything to go by I don't expect anything worthwhile to come from there.

All suggestions are welcome ...!
Nov 18, 2015 at 1:49 AM
Are you using the latest BIOS updates?

You can use Belarc Advisor to get your Main Circuit Board information.
Nov 18, 2015 at 2:22 PM
The BIOS is up-to-date, and hasn't been changed for quite some time.
Nov 18, 2015 at 2:41 PM
Another suggestion: uninstall the current VeraCrypt and then install the older version of VeraCrypt 1.0f-2 (
Try both RIPEMD-160 and SHA-256 for hash algorithm and always use AES (it has the lower memory usage).

Do you have the same error with 1.0f-2?

I'm suggesting version 1.0f-2 because its bootloader is smaller and its memory usage is identical to TrueCrypt one.
Nov 18, 2015 at 5:23 PM
Tests using VeraCrypt 1.0f-2 give the same result, specifying AES and either of the RIPEMD-160 and SHA-256 hash algorithms.

More and more, I'm beginning to wonder if this isn't a problem with some mainboard setting.
However, all mainboard settings I can see with UEFI disabled look OK to me.

Not sure what would happen if UEFI is enabled temporarily, in order to look at all mainboard settings available.
I'm afraid it would result in all HDDs and SDDs being re-initialised and all arrays destroyed ... does anyone know?
Nov 22, 2015 at 5:04 PM

Like I suspected, it did have to do with a BIOS setting.

The BIOS of my lappy contains a setting 'Intel Rapid Start Technology' which has something to do with faster resuming after the computer has been put to sleep.
This setting can either be enabled or disabled. But when it is enabled, the VeraCrypt boot loader simply doesn't work and the result is the error MMP:11 (I still have no idea what it stands for).

I don't know if this is anywhere in the VeraCrypt documentation, but if it is I never noticed.
And if it isn't, maybe it can be added ... it might save some people lots of time and frustration in future :-)

Thanks for the suggestions, they were much appreciated.