This project has moved. For the latest updates, please go here.

Upgraded from VeraCrypt 1.0f-2 to 1.15 and command line mount hangs machine

Topics: Technical Issues
Oct 20, 2015 at 2:06 PM
Recently upgraded install of VeraCrypt from 1.0f-2 to 1.15, a shortcut with command line switch that used to work with an encrypted container now hangs the system when double clicked and used successfully before upgrade.

If I mount the same container manually, it mounts without issue other than the usual pause of around 35seconds whilst VeraCrypt does it thing.

The shortcut icon with target line switch reads as follows - "C:\Program Files\VeraCrypt\VeraCrypt.exe" /q background /lV /m rm /v D:\Parts\V1024MB.hc - this worked with no problems up to 1.0f-2.

I understand that the /lV switch changed [now needs a space] around 1.12 or 1.13 to /l V - with this, I updated my target line switch to - "C:\Program Files\VeraCrypt\VeraCrypt.exe" /q background /l V /m rm /v D:\Parts\V1024MB.hc - and it still hangs the system.

/l v - mount as drive letter "V", /m rm - mount as removable media, /v D:\Parts\V1024MB.hc [path to the intended file]

I will presume one of the switch parameters is incorrect or incomplete but I cannot figure out which one, or, there are switch parameters I am not calling on that need to be used.

Looking for a little bit of assistance or guidance here guys if poss

Oct 20, 2015 at 3:00 PM
Edited Oct 20, 2015 at 3:00 PM
There are problems with 1.15 version causing extra drive letters to be mounted and the registry can have incorrect drive definitions.

First upgrade to 1.16 version.

With the all volumes dismounted, perform the following.

Using a modified version of Idrassi's instructions:
Check the registry key "HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices" using regedit. Scroll down and you'll find entries starting with "\DosDevices\" which indicate the drive letters that are taken by the system. Before mounting any volume, double click on each one and remove the ones contains the name "VeraCrypt" and "TrueCrypt".
Also, there are other entries whose name start with "#{" and "\??\Volume{": double click on each one of them and remove the ones whose data value contains the name "VeraCrypt" and "TrueCrypt".
Reboot PC.
Oct 20, 2015 at 7:56 PM
Enigma2Illusion thanks for your reply

Should have said in my first post that I had already updated to 1.16 earlier on today, rebooted and tried to command line mount same volume - same result. That was what prompted me to post a question on here in the first place.

More info offered from my end about the system VeraCrypt is running on - Full drive encryption with three partition layout as C:\OS, D:\DATA, E:\DVD-Rom, E:\DATA. There are not auto mount volumes involved, no favourites retained, just several encrypted containers, these used to be called upon as and when required with pre determined drive letter assignment via switches on the shortcut link, the password was manually entered before proceeding.

When moving this laptop from TrueCrypt to VeraCrypt, full TC drive was decrypted then re-encrypted with VC. When upgrading from VeraCrypt 1.0f-2 to 1.15, for safety sake and to remove any possible issues or glitches during upgrade [works laptop - time not an issue, data integrity and security was] a decision was made to fully decrypt drive, install new 1.15 version and re-encrypt full drive again. This time around, VeraCrypt was upgraded to 1.16 with 1.15 in-situ and running, followed by obligatory reboot, then creation of updated rescue disk.

Enigma2Illusion - I followed your registry suggestion as above and found no "\DosDevices\" with any mention of "VeraCrypt" or "TrueCrypt" listed, as it goes, I found no listing for drive letters "V" or above, which are\were my letter choices when mounting containers.

I still suspect my issue to be a switch based - would it be looking for PIM switch. As the entire drive is encrypted and the containers reside on the drive, I find it overkill to use a long password on the containers. Drive is encrypted with a 24 character password and containers have 12 -> 14 character passwords, PIM is left as default in all cases.