This project has moved. For the latest updates, please go here.

Encrypt a non-system partition/drive is failing on an SSD

Topics: Technical Issues
Sep 26, 2015 at 7:50 AM
Hello,

I have just encrypted all my non-os harddrives except for one, a 120GB SSD (Samsung 840 EVO) (35GB Free space, have also checked drive for errors, updated drive firmware and done health checks on it through Samsung Magician). Everytime I try encrypting it, I go through the whole process.

I get this error:
The parameter is incorrect.
Source: EncryptPartitionInPlaceBegin:530


Encrypt a non-system partition/drive ->
Standard Veracrypt Volume ->
Select Device (SSD, non-OS) ->
Encrypt partition in place->
Choose encryption methods and passwords ->
Move my mouse around for a minute like a maniac ->
No wipe, start encryption ->
It just says "Status: Resizing" for a while, less than a minute, and then throws this error ->

The parameter is incorrect.
Source: EncryptPartitionInPlaceBegin:530

After clicking OK in that error, I get a window saying

"Error: Cannot shrink the filesystem (the filesystem needs to be shrunk to make space for the volume header and backup header).

Possible causes and solutions:

-Not enough free space on the volume, please make sure no other application is writing to the filesystem.

-Corrupted file system. Try to check it and fix any errors.......

After that there are instructions on how to encrypt the drive in another way that I wasnt aiming for.."

I have tried all kinds of stuff from checking the disk for errors to googling about this issue but nobody seems to have an answer. Does anyone in here know what could be the problem?

Thank you in advance! :)
Sep 26, 2015 at 3:32 PM
Hello,

What format is the SSD formatted in prior to encryption? Should be NTFS.

What OS version and edition are you running?
Sep 27, 2015 at 7:21 AM
Hi!

The SSD is formatted in NTFS as are all my drives and Im currently running Windows 8.1 Professional 64bit.

Ive tried a few more tricks but nothing seems to help, I always get this odd error.
Sep 29, 2015 at 10:13 AM
Does anyone have any idea as to what could be the cause? Ive been digging and trying everything but nothing seems to work, its very odd.
Oct 10, 2015 at 10:33 AM
Ive pretty much tried everything now, still getting the same error despite trying anything Ive been able to come up with.

Does anyone have ANY clue at all as to what this error is?
Oct 10, 2015 at 3:09 PM
What anti-virus software are you using?

Have you tried disabling the AV software?
Oct 11, 2015 at 5:47 AM
I dont run any anti-virus software other than the default Windows Defender which I've tried disabling as well without any luck.
Oct 11, 2015 at 8:00 AM
Do you want to try to resize (shrink) your volume first using Windows "Disk Management"? (Available from the WindowsKey-X menu in Windows 8.1)
Oct 11, 2015 at 8:07 AM
I could try that. At one point it had 5GB free space, it still wouldnt encrypt. Then I removed a bunch of stuff (35GB free space) and tried again, still nothing. Currently theres 10GB free space. You think it could be possible that shrinking it a little could help solve the problem?
Oct 11, 2015 at 9:01 AM
Yes it may help.
Oct 20, 2015 at 7:50 AM
Thank you, it worked perfectly! :) Do you know the specifics behind as to why it requires shrinking? I shrinked the drive by 1 GB only and it started encrypting it instantly.

Once again, thank you for the help! Highly appreciated! :)