Veracrypt + network hard drive : Permission denied [Solved]

Topics: Technical Issues
Aug 30, 2015 at 9:29 PM
Edited Aug 30, 2015 at 9:31 PM
Hello everyone,

Forgive my bad English because I am French ...

I just migrate for the first time on Ubuntu 10.04 LTS 64-bit , being a former user of Windows ever since and more recently Windows 10 , I could perfectly open an encrypted file via Veracrypt placed on my network hard drive WDmycloud .

Being Ubuntu 10.04 LTS 64-bit , I do not open my encrypted file.

I get the following error message:

Permission denied :/run/user/1000/gvfs/smb-share:server=wdmycloud,share=sauvegarde/sauvegarde1 VeraCrypt::File::Open:232

http://www.hostingpics.net/viewer.php?id=799208Capturedu20150830160638.png


I said that I can fully access my network drive and thus to the encrypted files via the file manager, but again , when I want to open an encrypted file with VeraCrypt I encounter this error message and am in unable to decipher my file.

Under Windows 10 I had no worries to open an encrypted file on my network drive . Also I am asked my Ubuntu administrator password while in Windows 10 nothing was asked . In short I do not know at all or it may jam.

I look forward to your responses.
Regards,
Pierre
Coordinator
Aug 31, 2015 at 1:45 PM
Bonjour Pierre,

Vu que je suis français aussi, le mieux serait de formuler la question en Français et en Anglais...Je vais répondre en Anglais et je mets la version française en bas.

The error code indicates that VeraCrypt could not open the file in Read/Write mode. VeraCrypt uses a standard system function to do this ("open") and this function fails with the error displayed in the message.

The most plausible explanation is that you network drive is mounted in Read-Only mode. In this case, to solve the issue, mount the veracrypt container files as ReadOnly by clicking "Options" on the password dialog and checking "Mount volume as Read Only" as shown in the screenshot below:
VeraCryptLinuxMountAsReadOnlyScreenshot

This will most certainly solve your issue.
If you need to have write access to your volumes, you will have to find a way to share your drive in read-write mode.

Cheers,
Traduction Française

Le code d'erreur indique que VeraCrypt n'a pas pu ouvrir le fichier en mode lecture / écriture. VeraCrypt utilise une fonction système standard ("open") pour faire cela et cette fonction échoue avec l'erreur affichée dans le message.

L'explication la plus plausible est que votre lecteur réseau est monté en mode lecture seule. Dans ce cas, pour résoudre le problème, monter les fichiers conteneurs veracrypt en lecture seule en cliquant sur "Options" dans la boîte de dialogue de mot de passe et en cochant la carte "Mount volume as Read Only", comme indiqué dans la capture d'écran ci-dessous:
VeraCryptLinuxMountAsReadOnlyScreenshot

Cela va très certainement résoudre votre problème.
Si vous avez besoin d'avoir un accès en écriture à vos volumes, vous devriez alors trouver le moyen de partager votre lecteur réseau en mode lecture-écriture.
Aug 31, 2015 at 3:13 PM
Edited Aug 31, 2015 at 3:15 PM
Bonjour idrassi,

Je vais donc formuler mes réponses en français et en anglais. J'ai essayé votre solution mais malheureusement celle-ci ne fonctionne pas. En activant l'option "Mount Volume as read-only" j'ai toujours le même code erreur. Je précise que mon disque dur réseau avait déjà les droits en lecture et en écriture via son Admin pour les utilisateurs autorisés. Je tiens à préciser que je peux parfaitement accéder à mon disque réseau en lecture/écriture et ainsi avoir accès aux fichiers cryptés, mais concernant le décryptage je me heurte à ce message d'erreur.

English translation :

Hello idrassi ,

I will formulate my answers in French and English. I tried your solution but unfortunately it does not. By activating the " Mount volume as read -only" I still have the same error code. I said that my network hard disk already had the rights for reading and writing through its Admin for authorized users . I want to say I can fully access my network disk read / write and have access to encrypted files, but for decryption I encounter this error message .
Coordinator
Aug 31, 2015 at 4:55 PM
Bonjour Pierre,

I just noticed that the path to the file is not standard as it is more like a URL than a standard Linux path: /run/user/1000/gvfs/smb-share:server=wdmycloud,share=sauvegarde/sauvegarde1

I suspect that the standard function VeraCrypt uses ("open") is not compatible with this format.

How did you come up with this path?
If you entered it manually, can you please use the "Select File" button to select the container file.

When you display the file properties in Nautilus, what the location that is shown?
Je viens de remarquer que le format du chemin du fichier n'est pas standard du tout et il ressemble plutôt à une URL: /run/user/1000/gvfs/smb-share:server=wdmycloud,share=sauvegarde/sauvegarde1

Je soupçonne que la fonction standard "open" que VeraCrypt utilise n'est pas compatible avec ce format.

Comment avez-vous saisi ce chemin?
Si vous l'avez saisi manuellement, pourriez-vous s'il vous plaît utilisez le bouton "Select File" pour sélectionner le fichier conteneur.

Aussi, lorsque vous affichez les propriétés du fichier dans Nautilus, c'est quoi l'emplacement indiqué?
Aug 31, 2015 at 7:03 PM
Edited Aug 31, 2015 at 8:50 PM
Bonsoir idrassi,

Je n'ai pas saisi manuellement le chemin, j'ai utilisé le bouton "select file" de VeraCrypt et j'ai été sur : sauvegarde sur wdmycloud (qui est mon disque dur réseau), pour sélectionner ensuite mon fichier et donc monter sauvegarde1, j'obtiens ensuite l'erreur en question une fois le mot de passe saisi. Encore une fois sous Windows 10 tout fonctionne parfaitement.

Concernant les propriétés du fichier dans Nautilus voici le résultat :
Emplacement : smb://wdmycloud/sauvegarde/

Permission : Les permissions de "sauvegarde1" ne peuvent pas être déterminées.

----------------------------------------------------------------------------------------------------------------------


Good evening idrassi,

I have not entered manually the way, I used the "select file" button VeraCrypt and I was on: wdmycloud backup (which is my network drive), and then select my file and therefore mount sauvegarde1 I then get the error in question after entering the password. Again Windows 10 everything works perfectly.

Regarding the file properties in Nautilus is the result:
Location: smb: // wdmycloud / backup /

Permissions: The permissions of "sauvegarde1" can not be determined.
Coordinator
Sep 1, 2015 at 6:05 PM
Bonjour Pierre,

I was able to reproduce your issue and I found it was caused by the fact that the permissions of the shared files only allow the current Ubuntu user, not even root. But VeraCrypt launched the mount process as root to be able to create mount points and that's why it can't access the file.

The only solution that I found is to manually mount the network folder to a local directory. I will explain the steps:
  • Get the IP address of the server. Here we suppose it is 192.168.1.123
  • We suppose that the user name for Windows share is WINUSER and its password is WINPASS
  • We suppose that the current Linux user name is LINUSER
  • Create a directory called Sauvegarde.
  • Open Terminal and type the following command:
sudo mount -t cifs //192.168.1.123/sauvegarde /home/LINUSER/Desktop/Sauvegarde -o user=WINUSER,password=WINPASS
After that you will find, your containers in the Sauvegarde folder in the Linux desktop and you can mount them using VeraCrypt without a problem.
Je suis parvenu à reproduire votre problème et j'ai découvert qu'il est causé par le fait que les permissions des fichiers partagés ne permettent l'accès qu'à l'utilisateur d'Ubuntu courent, même pas au root. Or, VeraCrypt lance son processus de montage en tant que root pour être en mesure de créer des points de montage système et c'est la raison pour laquelle il ne peut pas accéder aux fichiers conteneurs.

La seule solution que j'ai trouvé est de monter manuellement le dossier de réseau dans un répertoire local. Je vais vous expliquer les étapes:
  • Obtenir l'adresse IP du serveur. Ici, nous supposons que c'est 192.168.1.123
  • Nous supposons que le nom d'utilisateur pour la partage de Windows est WINUSER et que son mot de passe est WINPASS
  • Nous supposons que le nom actuel de l'utilisateur Linux est LINUSER
  • Créez un répertoire sur le Bureau Ubuntu appelé Sauvegarde.
  • Ouvrez Terminal et tapez la commande suivante:
sudo mount -t cifs //192.168.1.123/sauvegarde /home/LINUSER/Desktop/Sauvegarde -o user=WINUSER,password=WINPASS
Après cela, vous trouverez vos fichiers conteneurs dans le dossier Sauvegarde sur le bureau Ubuntu et vous pourrez les monter avec VeraCrypt sans problème.
Sep 1, 2015 at 7:46 PM
Edited Sep 1, 2015 at 8:03 PM
Bonsoir idrassi,


Un grand merci à vous pour votre aide et votre recherche à mon problème. Je viens de saisir dans le terminal votre ligne de commande, malheureusement je n'arrive pas à monter manuellement le dossier du réseau. J'ai bien renseigné l'adresse ip de mon disque disque réseau ainsi que le nom d'utilisateur et le mot de passe. J'obtiens le message d'erreur suivant :
mount : le point de montage /home/Pierre/Desktop/Sauvegarde n'existe pas
Voici ce que j'ai renseigné :

sudo mount -t cifs //xxx.xxx.x.xx/sauvegarde /home/Pierre/Desktop/Sauvegarde -o user=WINUSER,password=WINPASS
J'ai créé le dossier Sauvegarde sur mon bureau. Pour information le chemin pour accèder manuellement à mon fichier crypté sauvegarde1 via Nautilus est le suivant :
Parcourir le réseau > WDMycloud > Sauvegarde > Sauvegarde1 (le fichier crypté).
Je précise que j'ai 4 dossiers qui s'affiches dans Parcourir le réseau :
* Livebox/ (admin de ma Livebox)

* Réseau Windows/WORKGROUP/LIVEBOX -- WDMYCLOUD

* WDMyCloud/Pierre -- Public -- Sauvegarde/(Case qui me demande de saisir le nom d'utilisateur et le mot de passe de mon accès au disque dur réseau)/Sauvegarde/Sauvegarde1 (le fichier crypté). 

* WDMYCLOUD/Pierre -- Public -- Sauvegarde/Sauvegarde1
---------------------------------------------------------------------------------------------------------------


Good evening idrassi,


A big thank you to you for your help and looking to my problem. I just enter in your command-line terminal, unfortunately I can not manually mount the network folder. I knowledgeable the ip address of my network hard drive as well as the user name and password. I get the following error message:
mount: mount point / home / Peter / Desktop / Backup does not exist
Here is what I have inquired:
sudo mount -t cifs //xxx.xxx.x.xx/sauvegarde / home / Peter / Desktop / -o user = winuser backup, password = WinPass
I created the Backup folder on my desk. For information the way to access my encrypted file manually sauvegarde1 in Nautilus is the following:
Browse Network> WDMycloud> Storage> Sauvegarde1 (which the encrypted file).
Note that I have 4 records in Browse Network:
  • Livebox / (admin of my Livebox)
  • Windows Network /WORKGROUP/LIVEBOX and WDMYCLOUD
  • WDMyCloud / (Peter and Public) and Backup / (CASA asks me to enter the user name and the password of my hard disk access network) / Backup / Sauvegarde1 (my encrypted file).
  • WDMYCLOUD / (Peter and Public) and Backup / Sauvegarde1
Sep 1, 2015 at 10:48 PM
Edited Sep 1, 2015 at 10:49 PM
J'ai finalement réussi à ne plus avoir de message d'erreur dans le terminal en utilisant le chemin suivant :
sudo mount -t cifs //xxx.xxx.x.xx/WDMyCloud/Sauvegarde/home/Pierre/Bureau/Sauvegarde -o user=xxxx,password=xxxxxx
En revanche rien ne figure dans le dossier Sauvegarde du bureau. J'ai une liste de commande qui apparait dans le terminal mais je ne sais pas quoi faire.
Utilisation : mount -V                 : afficher la version
              mount -h                 : afficher cette aide
              mount                    : afficher la liste des systèmes de fichiers montés
              mount -l                 : idem, incluant les étiquettes de volumes
Cela pour la partie informative. Suit ce qui porte sur le montage.
La commande est « mount [-t type-sys-fichier]  quoi  où ».
Les détails se trouvant dans /etc/fstab peuvent être omis.
              mount -a [-t|-O] ...     : monter tout ce qui est écrit dans /etc/fstab
              mount périphérique       : monter le périphérique à l'endroit connu
              mount répertoire         : monter le périphérique connu ici
              mount -t type périph rép : commande de montage ordinaire
Noter qu'on ne monte pas réellement un périphérique, on monte
un système de fichiers (d'un type donné) trouvé sur le périphérique.
On peut aussi monter une arborescence de rép. déjà visible ailleurs :
              mount --bind ancien-rép nouveau-rép
ou déplacer une sous-arborescence :
              mount --move ancien-rép nouveau-rép
On peut changer le type de montage d'un rép. :
              mount --make-shared rép.
              mount --make-slave rép.
              mount --make-private rép.
              mount --make-unbindable rép.
On peut changer le type de tous les points de montage d'une
sous-arborescence contenue dans le rép.:
              mount --make-rshared rép.
              mount --make-rslave rép.
              mount --make-rprivate rép.
              mount --make-runbindable rép.
Un périphérique peut être nommé, comme /dev/hda1 ou /dev/cdrom, ou
repéré par l'étiquette, avec -L étiqu. ou par UUID, avec -U uuid .
Autres options : [-nfFrsvw] [-o options] [-p descr_fic_mots_passe].
Pour plus de précisions, consultez « man 8 mount ».
----------------------------------------------------------------------------------------------------------




I finally managed to have no more error message in the terminal using the following path:
sudo mount -t cifs -o user = //xxx.xxx.x.xx/WDMyCloud/Sauvegarde/home/Pierre/Bureau/Sauvegarde xxxx xxxxxx password =
However nothing contained in desktop Backup folder. By BTW I have an order list that appears in the terminal but I do not know what to do.
Usage: mount -V: display version
              mount -h: display this help
              mount: list the mounted file systems
              mount -l: idem, including volume labels
This for the informative part. Suit bringing about mounting.
The command is "mount [-t type file-sys-] what where."
Details found in / etc / fstab can be omitted.
              mount -a [-t | -O] ...: up everything that is written in / etc / fstab
              mount device: mount device at the known place
              mount directory: mount known device here
              Device mount -t type dir: ordinary mount command
Note that does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
You can also mount a dir tree. already seen elsewhere:
              mount --bind old-dir new-dir
or move a subtree:
              --move mount new old-rep-rep
One can change the type of mounting a rep. :
              mount --make-shared dir.
              mount --make-slave dir.
              mount --make-private dir.
              mount --make-unbindable dir.
One can change the type of all mount points a
subtree contained in the dir .:
              mount --make-rshared dir.
              mount --make-rslave dir.
              mount --make-rprivate dir.
              mount --make-runbindable dir.
A device can be named, such as / dev / hda1 or / dev / cdrom or
spotted by the label with stick labels putting -L. or UUID with -U uuid.
Other options: [-nfFrsvw] [-o options] [-p descr_fic_mots_passe].
For more information, see "man 8 mount."

Coordinator
Sep 2, 2015 at 6:31 PM
Bonsoir Pierre,

I think there is a space missing your command between //xxx.xxx.x.xx/WDMyCloud/Sauvegarde and /home/Pierre/Bureau/Sauvegarde. The command should be:
sudo mount -t cifs //xxx.xxx.x.xx/WDMyCloud/Sauvegarde /home/Pierre/Bureau/Sauvegarde -o user=xxxx,password=xxxxxx
Can you please check this?
Je pense qu'il y a un espace qui manque dans votre commande entre //xxx.xxx.x.xx/WDMyCloud/Sauvegarde et /home/Pierre/Bureau/Sauvegarde. La commande devrait être:
sudo mount -t cifs //xxx.xxx.x.xx/WDMyCloud/Sauvegarde /home/Pierre/Bureau/Sauvegarde -o user=xxxx,password=xxxxxx
Est-ce que vous pouvez vérifier cela?

Can you please check this?
Sep 2, 2015 at 6:39 PM
Edited Sep 2, 2015 at 6:40 PM
Bonsoir Idrassi,

Je viens de copier/coller votre code et j'obtiens le message suivant :
le point de montage /home/Pierre/Bureau/Sauvegarde n'existe pas
-----------------------------------------------------------------------------------------------------------------------



Good evening Idrassi,

I just copy / paste your code and I get the following message:
the mount point / home / Peter / Office / Backup does not exist
Coordinator
Sep 2, 2015 at 6:46 PM
humm...what is then the correct path to the empty directory you created on the desktop?

In this part of the command, you must put the correct path to the empty directory where the shared files will be visible.
In order to see the list of folders that exist on the desktop, type the following command:
ls -l /home/Pierre/Bureau
Ah...c'est quoi le chemin du répertoire vide que vous avez créer sur le bureau?

Dans cette partie de la commande, il faut mettre le chemin correcte du répertoire vide où les fichiers réseaux seront visible.
Pour voir la liste des répertoire sur le bureau, tapez la commande:
ls -l /home/Pierre/Bureau
Sep 2, 2015 at 6:51 PM
Edited Sep 2, 2015 at 6:52 PM
I simply created a backup folder on the Ubuntu desktop. Looking in "explorer" Ubuntu My Backup folder appears in: Personal File> Desktop> Backup


----------------------------------------------------------------------------------------------------------------------------------------


J'ai simplement créé un dossier sauvegarde sur le bureau de Ubuntu. En regardant dans "l'explorateur" Ubuntu mon dossier Sauvegarde apparait dans : Dossier personnel > Bureau > Sauvegarde
Coordinator
Sep 2, 2015 at 9:36 PM
Your problem is that you don't know the correct path to your folder. This is an easy problem: right click on the folder and choose "properties" and you will see the following:
Image

then concatenate the values of location and name: this will give you the path. In my example, this gives: /home.mounir/Desktop + Sauvegarde = /home.mounir/Desktop/Sauvegarde
Votre problème est que vous ne connaissez pas le bon chemin d'accès à votre répertoire sur le bureau. Cela se résout facilement: faite un clic droit sur le dossier et choisissez "Propriétés" et vous verrez ce qui suit:
Image

puis concaténer les valeurs de "Emplacement" et le nom: cela vous donnera le chemin. Dans mon exemple, cela donne: /home/mounir/Desktop + Sauvegarde = /home/mounir/Desktop/Sauvegarde
Sep 2, 2015 at 11:03 PM
Edited Sep 2, 2015 at 11:06 PM
A great big thank you! I finally got to ride my encrypted file in the office of the backup file, I stated the following path:
sudo mount -t cifs //xxx.xxx.x.xx/Sauvegarde / home / queen / Office / Backup -o user = xxx password = xxxxx
I think in any case that really aberrant VeraCrypt default open encrypted files on the NAS drive via Ubuntu. I hope this problem will be reassembled in the VeraCrypt community to correct this problem. Do you know if it is possible to organize a macro command to run this command without having to copy and paste in the terminal?

Again thank you to you to be able to find the problem and provide a viable and functional solution.

----------------------------------------------------------------------------------------------------------------------------------------



Un grand grand merci à vous ! J'ai enfin pu monter mon fichier crypté dans le dossier sauvegarde du bureau, j'ai indiqué le chemin suivant :
sudo mount -t cifs //xxx.xxx.x.xx/Sauvegarde /home/pierre/Bureau/Sauvegarde -o user=xxx,password=xxxxx
Je trouve en tout cas vraiment très aberrant que VeraCrypt ne peut ouvrir par défaut des fichiers cryptés sur disque dur réseau via Ubuntu. J'espère que mon problème sera remonté au sein de la communauté de VeraCrypt afin de corriger ce problème. Savez-vous si il est possible d'organiser une commande macro pour exécuter cette commande sans devoir passer par un copier-coller dans le terminal?

Encore une fois merci à vous pour avoir trouvé le problème et apporter une solution viable et fonctionnelle.
Coordinator
Sep 3, 2015 at 11:02 PM
Happy to see that this resolved your problem.

You can create a file that you can run by double clicking on it to mount your network share. Create a file on the desktop, open it with the text editor and copy the command line to it after replacing sudo by gksudo.
gksudo mount -t cifs //xxx.xxx.x.xx/Sauvegarde /home/pierre/Bureau/Sauvegarde -o user=xxx,password=xxxxx
Save the file and then right click on it,choose properties then permissions panel and then check "Allow executing file as program". Click OK. After that, when you double click on the file, it will run and it will ask you for your Linux password. After that, your network share will be mounted.

UbuntuAllowExecuteFile
Je suis ravi de voir que cela a résolu votre problème.

Vous pouvez créer un fichier que vous pouvez exécuter en double-cliquant dessus pour monter répertoire réseau. Créez un fichier sur le bureau, ouvrez-le avec l'éditeur de texte et copier la ligne de la commande en remplaçant sudo par gksudo.
gksudo mount -t cifs //xxx.xxx.x.xx/Sauvegarde /home/pierre/Bureau/Sauvegarde -o user=xxx,password=xxxxx
Enregistrez le fichier, cliquez dessus avec le bouton droit de la sourie, puis choisissez Propriétés -> Autorisations, puis cochez la case "Autoriser l'exécution de fichier en tant que programme". Cliquez sur OK. Après cela, lorsque vous double-cliquez sur le fichier, il sera exécuté et il va vous demander votre mot de passe Linux. Après cela, votre répertoire réseau sera monté.

UbuntuAllowExecuteFile
Sep 22, 2015 at 12:40 AM
Edited Sep 22, 2015 at 1:11 AM
Bonjour idrassi,

Je reviens vers l'expert que vous êtes car je suis confronté à un problème depuis ma migration vers Kubuntu (j'étais avant sous Ubuntu), je n'arrive plus à monter mon dossier crypté dans le fameux dossier Sauvegarde. En effet j'ai le message suivant :
mount : périphérique bloc //xxx.xxx.x.xx/Pierre est protégé en écriture, sera monté en lecture seule
mount : impossible de monter périphérique bloc //xxx.xxx.x.xx/Pierre en lecture seule
En effet j'ai constaté que mes fichiers cryptés utilisent des droits d'accès avancés et du coup je n'ai pas la main sur les options. Je précise que les autres dossiers du disque dur non cryptés peuvent se monter sans aucun problème dans le dossier Sauvegarde de mon bureau Kubuntu, puisqu'ils utilisent des droits d'accès normaux. Que dois je faire pour avoir les droit et rendre du coup l’accessibilité aux fichiers cryptés?

Image

En vous remerciant par avance.

Hello idrassi ,

I return to the expert you are because I am facing a problem since my migration to Kubuntu ( Ubuntu I was before ) , I can no longer ride my encrypted folder in the famous Backup folder . Indeed I have the following message:


`
mount: block device //xxx.xxx.x.xx/Pierre is write protected , will be mounted read-only
mount: //xxx.xxx.x.xx/Pierre impossible to mount read-only block device
` Indeed I found that my encrypted files use advanced permissions and suddenly I did not hand over the options . I said that the other unencrypted hard drive folders can be installed without any problems in the Backup folder on my Kubuntu desktop , since they use normal access rights. What should I do to make the right and suddenly accessibility to encrypted files?

Thanking you in advance.
Nov 21, 2015 at 6:06 PM
idrassi wrote:
I was able to reproduce your issue and I found it was caused by the fact that the permissions of the shared files only allow the current Ubuntu user, not even root. But VeraCrypt launched the mount process as root to be able to create mount points and that's why it can't access the file.
Is it possible to launch the mount process as root and the IO process for file access (on network drives) with user privileges?

Best regards,
Ettore
Feb 14, 2016 at 12:25 AM
Edited Feb 14, 2016 at 12:27 AM
Bonjour,

J'ouvre à nouveau ce topique car je viens de migrer finalement sur Kunbutu qui me correspond mieux, malheureusement la commande suivante ne semble plus fonctionner.
sudo mount -t cifs //xxx.xxx.x.xx/Sauvegarde/home/Pierre/Bureau/Sauvegarde -o user=xxxx,password=xxxxxx
J'obtiens sous Kubuntu ce message :

mount: wrong fs type, bad option, bad superblock on //xxx.xxx.x.xx/Sauvegarde,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)

       In some cases useful info is found in syslog - try
       dmesg | tail or so.
root@oem-ThinkPad-11e:/home/oem#

Hello,

I open this topic because I have finally migrate again Kunbutu that suits me better, unfortunately the following command your order does not seem to work.
sudo mount -t cifs -o user = //xxx.xxx.x.xx/Sauvegarde/home/Pierre/Bureau/Sauvegarde xxxx xxxxxx password =
I get Kubuntu this message :

mount : wrong fs type bad option , bad superblock on //xxx.xxx.x.xx/Sauvegarde ,
       missing codepage or helper program , or --other error
       ( For Several filesystems (e.g. nfs, cifs ) you might
       need a / sbin / mount . <type> helper program)

       In Some cases useful info is found in syslog - try
       dmesg | tail or so.
root @ oem- ThinkPad - 11th : / home / oem #
Feb 14, 2016 at 1:43 AM
Edited Feb 14, 2016 at 1:44 AM
Problème résolu en installer la librairie CIFS
 sudo apt-get install cifs-utils
Apr 23, 2016 at 2:59 AM
cifs-utils
is already installed, even though it doesn't work on GVFS based desktop environments (e.g. Gnome, LXDE, Unity).

There is no problem with KDE's KIO Slaves, despite the fact that you have to enter your root password every time you want to mount/unmount an encrypted VeraCrypt volume on a network hard drive.

Regards,
Ettore