This project has moved. For the latest updates, please go here.

Win10 install failed

Topics: Technical Issues
Aug 25, 2015 at 8:59 PM

I had VeraCrypt 1.0f installed on my win 8.1 machine and I used it, nicely, on a (secondary) data drive. Recently I upgraded to Win10 (and followed that with a clean install).

I've tried installing 1.0f-1 and 1.13 but each time get an "Exception occurred" (modal) dialog box, followed by "Registration of the User Account Control support library failed."

I've tried varying the install options, and "Run as Administrator", turned off Avast temporarily, etc., to no avail. Any ideas?
Aug 30, 2015 at 6:42 AM
Follow-up ...

I turned off UAC and tried to install again. No go.

I tried the "portable" version of VerCrypt and that is currently working.

I suppose I could look at the Veracrypt source and research UAC support library Win10 updates. But don't hold your breath ... 8)
Aug 30, 2015 at 4:47 PM

This error happens when the installer fails to register some COM objects needed for UAC support. This is something that should not fail as it is pretty standard and the installer has full administrative privileges. Moreover, many users are have installed VeraCrypt on Windows 10 and no such error was reported.

I suspect something is messing with the registry or the COM objects typelib.
Did you try uninstalling VeraCrypt completely, rebooting and installing VeraCrypt again?

Does the "Exception occured" dialog contain more text? A screenshot can help on this.

Most importantly, can you please go to Windows Event Viewer and look for error/warning entries around the time the installer error happens? This will give us more information about what is wrong your machine.

Sep 3, 2015 at 10:46 PM
Edited Sep 3, 2015 at 10:48 PM

Since I wasn't able to install VeraCrypt there does not appear to be anything to UNinstall. I'll try RevoUninstaller though and see if that'll help.... The free version doesn't list anything.

I did reboot and try again. No, still gives the three modal dialog boxes: 1) "Exception Occurred." 2) "Registration of the User Account Control support library failed." 3) "Installation failed." I have screen shots but ... [I don't have Paint.Net installed yet and they're 3840 x 1200 resolution].

I did look at the Event Viewer. Good idea. I didn't really see anything happen, but I poked around some, deliberately did a failed install and this looks like it:

__Log Name: System
Source: Microsoft-Windows-DistributedCOM
Date: 9/3/2015 1:45:15 PM
Event ID: 10016
Task Category: None
Level: Error
Keywords: Classic
User: 4670K\ekv
Computer: 4670K
The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
to the user 4670K\ekv SID (S-1-5-21-2564366919-306026355-851646521-1001) from address LocalHost (Using LRPC) running in the application container Microsoft.WindowsStore_2015.8.25.0_x64__8wekyb3d8bbwe SID (S-1-15-2-1609473798-1231923017-684268153-4268514328-882773646-2760585773-1760938157). This security permission can be modified using the Component Services administrative tool.__

I tried looking in Component Services but there's just too much to look through w/o having a better idea how to drill down or what to drill down for.

I was running the install off a BitLocker drive so I moved that .exe onto a regular drive. Still same error. Just for grins I thought I'd install to a temp directory, in fact "C:\Temp". That worked. I uninstalled. Tried installing to my original desired directory "C:\Utility Programs\VeraCrypt\" and that failed. I tried to install to another temp directory "C:\Temp test\VC\" and that worked.

So there is something about my "Utility Programs" directory ... ? The Properties/Security tween the Test dir's and the Utility dir. appear to be quite similar.

Again, thanks for your time !