This project has moved. For the latest updates, please go here.

Can't access drives after Windows 8.1 Pro upgrade to Windows 10 Pro

Topics: Technical Issues
Jul 31, 2015 at 3:26 AM
Edited Jul 31, 2015 at 8:29 AM
Anyone else upgraded to windows 10 pro?

I just did and can't access any of my encrypted volumes. They mount, but you can't access them under windows 10.

They're all encrypted partitions, using NTFS.

Image


Things I've tried:

Changed volume key
Changed "header key derivation"

Currently un-encrypting a 3TB HDD, which is showing 27 hours till completion. Ugh.

I have 3 other drives which are 4TB each... So don't want to spend all that time un-encrypting and re-encrypting...

Plus I don't think I can interrupt the un-encryption process without loosing all data...

Meaning I'm stuck waiting for this, even if I wanted to downgrade back to windows 8.1.

Anyhelp would kindly be appreciated. Thanks!
Jul 31, 2015 at 10:32 AM
Hi,

I just created an account to hear about how well this program works under windows 10. Seems there are some problems here and there.
I would be good to know when this problem will be solved. I dont want to abandon TC and upgrade before these issues remain.

And lastly i want to say thank you for continuing the work after TC.
Coordinator
Jul 31, 2015 at 3:11 PM
I have done further tests on freshly installed Windows 10 machine (Home and Pro): no problem at all, being it opening existing disks or creating new NTFS volumes.

The only difference is that in your case you performed an upgrade from a previous Windows version. I suspect that the upgrade process has marked VeraCrypt in a certain way which make it not working with NTFS volumes (very strange...).

I will have to perform an upgrade process to try to reproduce. Meanwhile, it is easy to check that VeraCrypt works on freshly installed Windows 10 (confirmed on several machines).

Further exchanges on the issue tracker: https://veracrypt.codeplex.com/workitem/177
Aug 2, 2015 at 10:42 AM
Thanks for confirming idrassi, will try it in a day or two myself. Cheers.
I have a clean install now and will be moving from TC to this since you are updating the program and it just feels better to know the support is there incase :)
Coordinator
Aug 2, 2015 at 11:05 AM
Edited Aug 2, 2015 at 11:06 AM
For your information, it was discovered by user duntuk that the issues reported so far were caused by Apple Bootcamp drivers which has many issues on Windows 10. Disabling it solves VeraCrypt NTFS issues: https://veracrypt.codeplex.com/workitem/177#CommentContainer22
Sep 24, 2015 at 3:01 AM
I have the same issue on a recently updated windows 10 machine. I am not running Windows in bootcamp (it is a windows machine) so the bootcamp drivers are not the cause of the issue for me.

I cannot open a veracrypt mounted ntfs container which was created in windows 8.1 and cannot create new ntfs volumes. I can successfully create fat volumes or no format volumes. These cannot be reformatted as ntfs.

I note that the issue referred to above has been marked as "resolved" when clearly it hasn't.