This project has moved. For the latest updates, please go here.

Auto mount after login not working

Topics: Technical Issues
Feb 25, 2015 at 2:43 AM
Edited Feb 28, 2015 at 9:30 PM
I have made a volume a favorite and marked it to mount selected volume upon login. The password box comes up after logging in and when I type in the correct password in the box it quickly disappears, which of course is not normal, then later a box comes up with "Incorrect password or no VeraCrypt volume found" If I start VeraCrypt and manually mount the volume it mounts fine. I enabled automount in diskpart as recommended in another post but no difference after reboot. This worked fine in TrueCrypt but not since moving to VeraCrypt. Drive letter is not used. Using Window 7. Any ideas?
Feb 25, 2015 at 3:26 AM
What version of VeraCrypt are you running?

What type volume? (Disk, partition or file container)
Does the volume you want to mount show in the Favorites?
When you select that volume, what options are enabled (check-box)?

Have you verified that Windows has not already assigned a drive letter after you start the system? View the drive/partition in Disk Management.

If Windows has already assigned a drive letter to the volume, this will prevent the auto mount from working in System Favorites.

Here is how to remove the drive letter assignment from Windows 7.
  1. Do not manually mount the volume in VeraCrypt.
  2. In Windows, use the Disk Management (Control Panel > Administrative Tools > Computer Management > Disk Management)
  3. Right click the raw partition (Windows will see this as a raw partition) and choose Change Drive Letter and Paths, and then Remove.
Reboot to determine if VeraCrypt is auto mounting the volume. If not, verify Windows did not reassign a drive letter at boot-up.
Feb 25, 2015 at 3:31 AM
Hi, below are answers to your questions.

Version 1.0f-1
file container type volume
yes it shows in favorites
only option checked is mount selected volume upon logon
Yes I have verified Windows has not assigned the drive letter in Disk Management
Feb 28, 2015 at 9:29 PM
Any other info that might help or something I could try?
Feb 28, 2015 at 10:09 PM

Just to confirm: after you type the password, do you see the "please wait" dialog or is it never displayed?
After how much time the wrong password dialog is displayed?
Are you checking TrueCrypt Mode in the password dialog?
Are you selecting the correct PRF or are your using Autodetection? Can you check if switching between Autoselection and manual selection makes any difference?

Since the wrong password message is displayed, this means that the VeraCrypt device driver didn't receive the correct information about the volume. Since you are sure you entered all correct information, I don't see for now how this can happen...this is a mystery but hopefully your answers will help narrow down its origin.
Mar 1, 2015 at 12:16 AM
Edited Mar 1, 2015 at 12:23 AM
Hi, the normal "please wait" dialog is not shown when I try to login from the dialog that automatically pops up on login.
"Incorrect password or no VeraCrypt volume found" dialog appears in 3 minutes and 42 seconds when Autodection is selected less if manually selected.
Not checking TrueCrypt mode in password dialog. Tried checking it, no difference.
Using Autodetection, tried manual selection, no difference.

Don't know if it means anything but I notice the dialog shown on login contains the text "Enter VeraCrypt Volume Password" in dialog's title bar but if I close it and manually mount it the same dialog then contains "Enter password for F:\filename.hc" in the dialog's title bar and putting in the password shows the "please wait" dialog and mounts the container fine shortly afterwards.
Mar 1, 2015 at 12:25 AM
Did you encrypt your OS?

If yes, this might may be a new bug related to an issue I discovered in TrueCrypt which impacts VeraCrypt.


I am running Windows 7 Pro 64-bit using VeraCrypt v1.0f-2 Beta.

I created a test file container on my external drive, mounted the file container to add to Favorites with the check box enabled for Windows logon. Dismounted the file container and rebooted my system.

Each test I performed was successful. Including Autodetection or selecting the correct PRF (hash) with and without a Windows OS password.
Mar 1, 2015 at 12:31 AM
No I have never encrypted my OS.
Mar 1, 2015 at 12:36 AM
Can you check the Events Log for errors on mounting the F drive at the time of failure?
Mar 1, 2015 at 12:46 AM
Another idea is to disable your software you are using for Antivirus, Malware and Firewall security and then reboot your system.
Mar 1, 2015 at 12:58 AM
Edited Mar 1, 2015 at 1:24 AM
No errors in event log regarding F drive. The F drive can be accessed fine before and after putting in the password. I have tried changing some preference settings in hopes one might help and started to suspect one of the preferences I changed was interfering with this working properly. I was not sure what I had changed and did not see a reset preferences to defaults so I uninstalled VeraCrypt and reinstalled the same version, made the volume a favorite again and the only setting I changed was to mount the favorite on login and rebooted and this time it worked as it was supposed to. I am not sure what setting it was, if any, but looking at them I believe the following were set the opposite of what they are now so perhaps it was one of them, seems unlikely though.

Used to be checked now unchecked

Mount volumes as removable media
Start VeraCrypt background task

Used to be unchecked now checked

Preserve modification timestamp of file containers

Anyway, thanks for the help.