After restar my password it's not working on my Veracrypt Voulme

Topics: Technical Issues
Feb 24, 2015 at 11:21 AM
Hi people.

After restar my computer my password it's not working on my Veracrypt Voulme. There is any issue with this?
Feb 24, 2015 at 12:48 PM
Edited Feb 24, 2015 at 2:31 PM
The likely problem in cases like this is the header has been corrupted by other software or hardware issues.

Assuming this is not system encryption, have you tried mounting using the embedded backup header? You can find this option when you mount the volume.

Did you make external backup of the headers using the Volume Tools? If yes, try restoring the headers.
Feb 25, 2015 at 5:34 PM
Edited Feb 25, 2015 at 6:49 PM
I don't have any backup of the headers :( could be other way to fix this issue?
Feb 25, 2015 at 6:53 PM
Did you attempt to mount the volume using the embedded backup header?
  1. Select the volume.
  2. Click the Mount button.
  3. Click the Mount Options button.
  4. Check the box for "Use backup header embedded in volume if available".
  5. Click OK button.
  6. Enter password and click OK button.
Feb 25, 2015 at 7:06 PM
Edited Feb 25, 2015 at 7:06 PM
I already tried that option. But failed too. :( with the same password problem.
Feb 25, 2015 at 7:37 PM
Remember that using "numpad" and the "numbers" is not the same. Write the password as you did first time...
Feb 25, 2015 at 7:43 PM
I don't have any backup of the headers :( could be other way to fix this issue?
.
I am going to ask some questions to determine if there are other options available to retrieve the data.

Is the volume encrypted disk, partition or file container?

Did you dismount the volume before restarting your computer?

Do you have backups of your data?
If file container, do you have backups of the file container when it was dismounted?

How often have you mounted this volume before you rebooted your computer?
Feb 25, 2015 at 9:27 PM
Edited Feb 25, 2015 at 9:28 PM
1) Disk Partition, over 700GB on Linux OS
2) I Had a System Crash, and i couldn't dismount :(
3) Not recently :'(
4) What do you mean how often, I always use this volume after Truecrypt died. But i had more or less 3 weeks without restart my system.


I have the following question, where is suppose to be save the header(Patth), to see if it's there...?
Feb 25, 2015 at 9:45 PM
I have the following question, where is suppose to be save the header(Patth), to see if it's there...?
.
See the documentation for the VeraCrypt Volume Format Specification.
Feb 26, 2015 at 3:50 AM
Edited Mar 3, 2015 at 5:11 PM
OMG! :( and i just lost my volume? :s i had 5+ years with Truecrypt and i never had a problem similar like that.

WTF

Coordinator
Feb 26, 2015 at 7:48 AM
Hi,

I have just read the discussion and from what I understand the encrypted partition was mounted for 3 weeks and after a system crash you are no longer able to mount it.
From the point of view of VeraCrypt, I don't see how this would cause the password not being accepted anymore apart from a hardware failure. Moreover, even the use of the backup header does not work for you: since the backup header is present at the end of the drive, this would mean that both the beginning of the drive and its end are corrupt.
VeraCrypt never write data to the volume header not to its backup during use phase and it only reads it in order to mount the volume. So, VeraCrypt could not corrupt the volume header or its backup.

You seem to be running on Linux. TrueCrypt and VeraCrypt under Linux delegate read/write operations of the encrypted volume to the Linux Kernel dm-crypt module which is part of the device mapper architecture: once the volume is mounted, everything is handled by the Linux Kernel. Thus, if anything went wrong during the system crash, it can't be blamed on VeraCrypt.

What most people don't know is that on Linux, TrueCrypt and VeraCrypt are limited to unlocking volumes and this limits any risks coming from bugs they may contain.

Moreover, using a hard drive for more than 5 years and suddenly starting to have issues is something very common. It is possible that your drive actually failed during the 3 weeks it was mounted and you started noticing it after rebooting the system.

TrueCrypt forums were full of people complaining about failures to mount volumes and I expect the same for VeraCrypt. The most common reasons are:
  • Hardware failure: users tend to keep sensitive data in hard drives for many years without taking into account the fact that failure rate increases each year. A better approach is to change the drive after 36 months as explained in this article: http://www.extremetech.com/computing/170748-how-long-do-hard-drives-actually-live-for. This link about hard drive reliability is also interesting: https://www.backblaze.com/blog/hard-drive-reliability-update-september-2014/
  • Password forgotten or changed: many users forget their passwords or they forget that they have changed it and they keep using the old one.
  • Keyboard layout: some users don't know the real value of the password (never used the show password) and if they change their keyboard layout (for example by using another machine) they start having issue because what they type is not mapped to the same original password.
  • Accidental formatting of the encrypted volume: it happens that some software writes data to the encrypted disks, corrupting volume header but usually one can mount the volume using the backup header.
As a conclusion and judging by all the element you posted (running on Linux, backup header not working, system crash, 5 years old drive), the most probable scenario is a hardware failure of the disk caused a crash of the Linux Kernel which handles read/write operations of the encrypted volume.
Of course I excluded that fact a program accidentally formatted your partition.
Feb 26, 2015 at 11:25 AM
This is a new laptop(just 6 Months), i don't think the problem resides on it. When i type the password, i'm using the show password option, just to be sure. And i've confirm that the password is the same. I don't really know what could be happening.

BTW: I don't have the header's backup.
Coordinator
Feb 26, 2015 at 4:14 PM
In your message you seemed to say that the drive was more than 5 years old...maybe you were talking about your use of TrueCrypt but in this case it doesn't prove anything about VeraCrypt implication in your issue.

Concerning the backup header, it is inside the drive itself as I said previously: it is embedded at the end of the drive and VzraCrypt will use it when you check the corresponding option in the password dialog.

Since you already tried the backup option:
* either all the partition is corrupted or has been formated
* or the supplied password is not correct.

There are no other explanations since you already mounted the volume successfully before: VeraCrypt will always do the same computation if you supply it with the same password and it will never overwrite the partition header and its backup if you don't explicitly change the password.



Feb 28, 2015 at 11:51 AM
Edited Feb 28, 2015 at 11:58 AM
I use my Truecrypt in an older laptop, when i changed to the new one i installed Veracrypt(clean) .

The last job I did with Veracrypt was to change the password to a strenght one, before this i write first the password in a crypto file in other device, and put in a save place, i'm typing the exact same password, but i got the issue :s
Coordinator
Feb 28, 2015 at 10:35 PM
The fact that you changed the password is an important information.
Did you try mounting it after changing the password or did the system crash happen before you could do that? Did you try with the old password?
Are you using PRF autodetection or do you specify the PRF manually?

Mar 2, 2015 at 11:12 AM
Edited Mar 2, 2015 at 2:22 PM
After i changed the password i mounted a couple of time with any issue. i don't know what PRF means, but if you are asking for the automount option, i always use manually. For a last resoruce i tried to detect and mount automatically, but it didn't work.
Mar 2, 2015 at 1:54 PM
Edited Mar 2, 2015 at 1:57 PM
PRF stands for PseudoRandom Function. PRF means the hash algorithm. I wish all the references to PRF were replaced by hash in the GUI since most non-techie people have heard of a hash algorithm instead of PRF.