This project has moved. For the latest updates, please go here.

incorrect password or no vc volume found - on simple setup?

Topics: Technical Issues
Jan 31, 2015 at 10:05 PM
Running LM17 Cin 64 bit. I just installed VC for first time. Running 1.0f-1.

See screenshots & volume at link below. Created a simple 1mb volume with password '123'. I cannot mount it? THe mounting attempt fails after a few minutes? What am I doing wrong?

https://www.mediafire.com/folder/ax9cz0k86u99z//veracrypt
Coordinator
Jan 31, 2015 at 10:56 PM
VeraCrypt has been tested on Linux Mint 17 and it is working with no issue (there is even a positive review about this on the home page).

I don't see what can be wrong. The procedure shown in the screenshots should work (by the way, to reduce mounting time, you can select the correct PRF in the password dialog (in your case SHA-512))

Unfortunately, it is not possible to download the container you put on the link (the server returns internal error), so it is not possible to check here if the password is correct.

Just a question: did you open the container file with an application that may have corrupted its content without you noticing? For now, I see only two possible explanations: either the file has been corrupted for some reason or you are not selecting the correct file.
Feb 1, 2015 at 2:47 PM
Not sure why you cant download. I added a zip of the same container file to mediafire.

I am not sure how I would have corrupted, I literally made the file and then tried to open all within 5 minutes. I did not move or rename the file (would that even affect?). Unless something running on my system is corrupting? I do have encryption enabled for the file system, but since that is decrypted and mounted, should that matter?

I will try from scratch a few more times....
Coordinator
Feb 1, 2015 at 2:48 PM
I have just tested on Linux Mint 17.1 Cinnamon 64-bit with the latest updates and after installing VeraCrypt I was to create a volume with the same parameters as you and it is mounted with no problem.
So clearly VeraCrypt is not at fault here, probably you just tried to load of the wrong container file
Feb 1, 2015 at 3:49 PM
I just recreated from scratch in a webm video I added to mediafire. Also added the created container in raw and zip format. Can you please look at to see what I might be doing wrong? Should I try reinstalling VC and if so, can you explain how I might do that? I really appreciate it.
Coordinator
Feb 1, 2015 at 5:16 PM
This time, I was able to download your two containers (test and vc) and I was able to mount them successfully both on Windows and on Linux Mint 17.1 Cinnamon 64-bit (password abc and 123 respectively).
Thus, the volume are OK and the issue is on the mounting. Are you using the official VeraCrypt binary? which version? You can always re-install VeraCrypt by downloading the Linux package (here), extracting the archive and then launching the appropriate installer in Terminal (in your case veracrypt-1.0f-1-setup-gui-x64). Follow the instruction and VeraCrypt should be available.

In the video, during the mounting process, the waiting dialog is not visible and this is not normal and very suspicious. You should see the same waiting dialog as the one displayed during the creation of the volume. This should never happen with the official binary.

Are you using the Mint 17.1? If not, can you update to 17.1?

Other actions to perform:
  • Go to menu "Tools -> Test Vectors" and click on "Auto-Test All". The tests should pass.
  • Go to menu "Settings -> Preferences" and select the tab "System Integration" . There, check "Do not use kernel cryptographic services". Click yes on the warning and then OK and retry the mount operation.
I hope all these elements will help us understand what's happening in your machine.
Feb 1, 2015 at 8:21 PM
Here's how I installed:
I downloaded from https://veracrypt.codeplex.com/downloads/get/1372347

Open file in archive manager and extract "veracrypt-1.0f-1-setup-gui-x64". Then within the same window or directory that contains "veracrypt-1.0f-1-setup-gui-x64" open terminal and enter:

Code: Select all
    chmod +x veracrypt-*
    ./veracrypt-*
I added a screenshot from terminal. I believe I am on 17 not 17.1.
  Distro: Linux Mint 17 Qiana
cabal@zareason ~/Downloads/temp/vc $ cat /etc/*-release
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=17
DISTRIB_CODENAME=qiana
DISTRIB_DESCRIPTION="Linux Mint 17 Qiana"
NAME="Ubuntu"
VERSION="14.04.1 LTS, Trusty Tahr"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 14.04.1 LTS"
VERSION_ID="14.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
cat: /etc/upstream-release: Is a directory
The tests seem to pass. I changed the 'system integration' and reran the test, created a new volume and trying to mount, and it didnt work.

I will upgrade to 17.1 and report results.
Feb 1, 2015 at 9:10 PM
OK, upgraded to 17.1 but no difference. Should I uninstall and reinstall again w a different method?
Coordinator
Feb 1, 2015 at 10:30 PM
Does the waiting dialog appear this time when you mount the volume? This was the most suspicious thing in the video.

I have no clues about what is happening on your machine, it defies logic!!! on my side or for other users, there are no problem and I can't understand why on your machine the volume creation would work while the mounting not.

The only things left to test:
  • Load the volume using the command line: sudo veracrypt --text /home/cabal/Desktop/test /media/veracrypt1 -p abc --hash=SHA-512 --protect-hidden=no
  • Installer the console version of VeraCrypt (veracrypt-1.0f-1-setup-console-x64) and execute the same command line above.
If this works, it means there is a gui issue on your machine. If this also does not work, then I'm afraid your machine has something special that I can't understand.
Feb 1, 2015 at 10:43 PM
I do not think there was any waiting dialog, no. However your terminal line seemed to work. When I ran the command, it opened a "veracrypt1" folder.
~ $ sudo veracrypt --text /home/cabal/Desktop/123 /media/veracrypt1 -p 123 --hash=SHA-512 --protect-hidden=no
Enter keyfile [none]: 

(process:5402): GLib-GObject-CRITICAL **: g_type_class_unref: assertion 'g_class != NULL' failed
(I already deleted the test file so was usin a 123 file)
Coordinator
Feb 2, 2015 at 1:40 PM
The fact that the mounting worked from the command line is a positive result: it means there is no issue in VeraCrypt with respect to mounting volumes and that the error is certainly lined to a GUI problem.
This is reinforced by the fact that the waiting dialog doesn't show up in your machine whereas on other Mint installations it is displayed as expected.

In VeraCrypt, the volume mounting is implemented in a thread linked to this waiting dialog and if there is an issue with this dialog, then the mounting will certainly fail.

The next step is to understand why this important dialog is not showing up on your machine. I really wished I could have access to do some debugging...

In your video, I see that the waiting dialog is displayed correctly during the creation of the volume, so the issue is not linked to this dialog specifically.

Very puzzling...if I compile a special version which traces information to the console, can you run it? I will try to print information about the execution path so that I can see what is happening.
Feb 2, 2015 at 2:39 PM
Yes, I would be happy to try running a special version. Just let me know how to run it/install it. I can provide you with my contact info if need be.
Coordinator
Feb 11, 2015 at 7:25 PM
An update on the issue: I had off-list exchanges with geniebottle (thank very much for your patience by the way) and he performed different tests with different binaries.
The results are simply amazing: the VeraCrypt process in his machine is not able to display certain dialogs (like simple message boxes) and more surprisingly, it was impossible to print any message to the console of Terminal or to create files in /tmp. This is unheard of and I can't find any explanation to this.

As noted above, VeraCrypt works flawlessly if the --text switch is used.

If anyone has a similar issue on Mint 17 or other Linux distribution, please post a message here so that we can check if there is a common software between you all that may be causing this amazing issue.
Mar 9, 2015 at 10:46 AM
doh! Whole thing a misunderstanding - I was clicking "auto mount" not "mount".... I thought that's exactly how I did in Truecrypt for cotainer files... but alas it was not the right function here....
Coordinator
Mar 10, 2015 at 2:09 AM
Edited Mar 10, 2015 at 2:10 AM
Thank you geniebottle for your update.

Actually, you are not the only one that have made this mistake as I received another report few hours ago on Sourceforge from a user who was clicking "Auto-Mount Devices" to mount the encrypted drive he had just selected and he didn't understand why it tool so long, whereas he should have clicked on "Mount"

It appears that this "Auto-Mount Devices" is causing confusion among some users...should we use a better label text?

The documentation of the "Auto-Mount Devices" operation is here: https://veracrypt.codeplex.com/wikipage?title=Main%20Program%20Window#AutoMountDevices
Mar 10, 2015 at 1:28 PM
idrassi wrote:
It appears that this "Auto-Mount Devices" is causing confusion among some users...should we use a better label text?
.
Here are some suggestions after reading the documentation on Auto-Mount Devices:
  • Search & Mount Devices
  • Find & Mount Devices
  • Seek & Mount Devices
Mar 11, 2015 at 12:06 AM
I could have sworn I used "auto mount" in TC on the same machine, and even though the containers were not external drives, it worked. Maybe a more descriptive error message too? Thanks for your hard work!