This project has moved and is read-only. For the latest updates, please go here.

50% encrypted - does not boot anymore - any chance to rescue files?

Topics: Technical Issues
Oct 18, 2014 at 3:28 PM
Hey there!

I've been encrypting my whole disk drive up to about 50%. Then I changed my mind and started to decrypt it again. The program told me I could pause the process and may continue anytime later, but Windows did not boot afterwards. It didn't even ask me for the veracrypt password.
However I got myself a new hard drive and installed Windows all over. My issue is that I do need a few files from my old drive.
Is there any chance I could rescue my old data? (I have that emergency disk and I know the password to decrypt. I also bought an adapter to use my old hard drive like an external storage which basically works but the partitions are obviously still encrypted.)

Thanks and all the best,
Oct 19, 2014 at 4:01 PM
Just tried to boot from USB (my old hard drive through an USB adapter) and it shows me the VeraCrypt bootloader.
Then I typed my password in, waited for about a minute. After that there was written 'booting'. Everything went on normal. I expected the Windows login screen to appear, instead I got and keep on getting a bluescreen... any ideas?
Oct 19, 2014 at 11:45 PM

I spent time trying to figure out what is happening with your installation.
Obviously the bootloader was working since the boot test worked before your could start the encryption. Decrypting doesn't affect the bootloader until the drive is fully decrypted so pausing the decryption doesn't have any impact.
Since you didn't even get the VeraCrypt password prompt upon rebooting, it means your bootloader has been corrupted or your hard drive has read problems.

You message today shows that the bootloader is OK since you can boot from USB (This only adds to the mystery!). The bluescreen of Windows is due to the fact that Windows expects Windows to be on internal hard drive and not USB and that's what is causing the error.

I think the most probable reason is that your hard drive is starting to show signs of fatigue/defects and that's why the bootloader is not always read correctly.

In order to retrieve your data, the most reliable way is to use the rescue disk created by VeraCrypt when you encrypted Windows : put back your old hard drive on the PC as it was before (SATA/IDE, not USB) and boot from the rescue disk : in the password prompt, press F8 (repair) and there you have several options.
  1. At first, you can try "Restore VeraCrypt Boot Loader" and see if you can boot Windows again.
  2. if this doesn't work, then you can choose "Permanently decrypt system partition/drive" : this will decrypt your hard drive but much slowly than under Windows.
I'm confident this solution based on the rescue disk will help you decrypt your hard drive. Of course, this supposes that the hard drive is not defective.
Oct 20, 2014 at 12:06 AM
Edited Oct 20, 2014 at 1:05 AM
Thanks for your kind reply, idrassi.

Actually, I was trying to boot from the rescue disk first, but I wasn't able to change the boot order as there appeared to be only one screen (like frozen) and no options to choose from. When I hit some buttons it just gave me an unfriendly beep in return.

Tomorrow I'm going to give it another try and report back.
Oct 20, 2014 at 4:33 PM
Edited Oct 20, 2014 at 11:09 PM

Unfortunately, the screen above is all I get to see when I plug my old drive back in. Nothing happens when I click F2 or F12...
Oct 20, 2014 at 10:23 PM
Apparently you posted an image but it doesn't display (there is only the word image). You should post its url again as text.

Just a question: did you boot on the rescue disk? The rescue disk menu was displayed? In order to choose an option from the rescue disk menu, you have type the number that correspond to the entry, for example 2 or 3 (not F2 or F3). Maybe you tried the function keys F2...F12 which don't work.
Oct 20, 2014 at 11:14 PM
Edited Oct 20, 2014 at 11:52 PM
Fixed the image.

I was trying to boot from the rescue disk but I can't select the 'F12 option' as clicking the button doesn't have any impact. The computer is like frozen to that screen above.
Oct 21, 2014 at 1:49 PM
It appears you have a problem with your motherboard or at least the old hard drive is causing trouble to it...this is a hardware issue and it's difficult to advice you about the best way to go since it is outside the scope of VeraCrypt.

One possibility though is to connect the old hard disk using the USB adapter and to use VeraCrypt to mount the disk by clicking "Select Device" and in the mount options dialog, check "Mount partition using system encryption without pre-boot authentication".
Oct 21, 2014 at 3:08 PM
Well, the mainboard works just fine with my new hard drive. You might be right and the old one got harmed.

I can't mount the old hard drive - I get this error:

By the way, that's what it looks like when I click "Select Device" (tried all of them):

Do you think I could plug my old drive to another IDE/SATA port on my desktop PC and then boot there from the rescue disk? And if so, does VeraCrypt recognize the right (encrypted) disk drive for the reparation process?
Oct 21, 2014 at 5:12 PM
Well, in your case the only solution is the use of the rescue disk.

The rescue disk looks for the first boot drive and use it by default. If you plug your old drive in a desktop PC, then you should either temporary deactivate your current drive (in the BIOS, the easy way) or unplug it so that the rescue disk points to the old drive. From there, you can fully decrypt your old drive.