This project has moved and is read-only. For the latest updates, please go here.

VeraCrypt Error on Raspberry Pi 2, Raspbian Jessie Lite

Topics: Technical Issues, Users Discussion
Feb 9 at 6:45 AM
I am having trouble with the Raspberry version of VeraCrypt. I have tested this on other machines (linux mint, not raspbian) and the console works fine, but not for Raspberry Pi 2 (ARM). I have searched for information, but none available worked for me.

The error message (after running the mount command described below);
Error: device-mapper: create ioctl on veracrypt1_1 failed: Device or resource busy
Command failed

This is how I installed it;
Installing VeraCrypt (console version) on Raspberry Pi 2:

Download the Raspbian version of VeraCrypt:
tar xvf veracrypt-1.19-raspbian-setup.tar.bz2
Run it:
bash veracrypt-1.19-setup-console-armv7
Download the missing Library:
sudo apt-get install libwxbase3.0-0
Done installing.

The command I use to mount a working VeraCrypt device without any prompts:
veracrypt --pim=0 -p <PASSWORD> -t -k "" --protect-hidden=no /dev/sdXn /mnt/<EXISTING_FOLDER>
Raspbian Device Info:
OS: Raspbian Jessie Lite
Version: January 2017
Release date: 2017-01-11
Kernel version: 4.4

I hope to get this problem solved, so that I may document this for other rasbian users that may encounter the same problem on current rasbian jessie lite + rasberry pi 2. :)