This project has moved. For the latest updates, please go here.

Stopped prompting for password after first restart

Topics: Technical Issues
Feb 1 at 9:40 PM
I installed VeraCrypt on the system partition using all the defaults. On restart after the encryption
process I was prompted for a password. That was the only time. The VeraCrypt icon shows that the partition is 100% encrypted so I know it is running. How do I turn the password prompt back on?
Thanks for any help.
Developer
Feb 2 at 6:27 AM
Feb 2 at 2:16 PM
Hello Alex,

I think the issue tnovak is encountering is the default Windows Fast Startup is enabled.

https://sourceforge.net/p/veracrypt/discussion/technical/thread/ab96939d/#e63b

As Mounir stated, VeraCrypt needs to disable the Windows Fast Startup feature which requires a reboot to take effect. You could have VeraCrypt background process check the setting when running to change the setting and request reboot and/or whenever any VeraCrypt volume is mounted for both system and non-system encrypted volumes.

Any progress of getting this enhancement made to the VeraCrypt software?

https://veracrypt.codeplex.com/workitem/475
Developer
Feb 2 at 6:41 PM
Fast startup issue is important. Probably VeraCrypt has to warn about it after any startup. Reason => passwords can be cached by system and it is not encrypted on shutdown.

If fast startup is enabled it works like hibernation simplified => passwords saved. It is known issue - Hybrid boot and shutdown.
https://veracrypt.codeplex.com/wikipage?title=Issues%20and%20Limitations

At present moment I'm working on full disk/hidden os encryption support for EFI.