This project has moved and is read-only. For the latest updates, please go here.

Missing Hash algorithms for system drive encryption

Topics: Technical Issues, Users Discussion
Jan 16 at 5:08 AM
I had a hard drive encrypted and I wanted to change the algorithm and hashing algorithm from AES with SHA-512 to AES with Whirlpool for hashing. Whenever I try to make a container all the algorithms are shown like usual but when I try encrypting my hard drive only SHA-256 and RIPEMD-160 are shown for the hashing algorithms. I've tried reinstalling VeraCrypt and I also completely removed it and got a new installer then verified it with the PGP key. I'm still having the same issue. I am running Windows 10 Home edition(64-bit version) and VeraCrypt 1.19 (64-bit version).

If anyone could help me, I would appreciate it a lot. Let me know if you need anymore information.
Jan 16 at 7:03 AM
I tried formatting the System Reserved partition because I thought it was using too much space causing the issue. After restoring it only SHA-256 and RIPEMD-160 are shown still. I'm going to try VeraCrypt 1.18a. I couldn't find a 1.19a version.
Jan 16 at 7:12 AM
Same results with older version.