This project has moved. For the latest updates, please go here.

Problem mounting volume using script

Topics: Users Discussion
Jan 15 at 12:11 AM
I've just moved from TC to VC but can't seem to mount volume using scripts.

Can anyone shed light on why the script below is not working. When I run it the volume is not mounted. Instead I get the password entry window.

"C:\program files\Veracrypt\Veracrypt" /v \Device\Harddisk2\Partition2 /l w /k Keyfile /h n /q /b

Thanks.

Regards,
Charles
Jan 15 at 9:10 AM
I assume you are using a keyfile with an empty password. I think you need to add the switch /s to stop the (redundant) password window from appearing.
Jan 15 at 4:00 PM
Adrian,

Thanks for the reply.

When I add /s to the password window does not appear but the drive is not mounted.

Regards,
Charles
Jan 15 at 8:03 PM
Edited Jan 15 at 8:04 PM
If you are using an empty password, you also need to add the '/tryemptypass y' switch.
Feb 12 at 9:49 PM
Thanks Adrian. That worked nicely.

Regards,
Charles