This project has moved and is read-only. For the latest updates, please go here.

Veracrypt usb disk - removed volume by windows

Topics: Technical Issues, Users Discussion
Oct 20, 2016 at 9:54 AM
Hello there.
I have a big problem with my usb disk which was encrypted by veracrypt. Encryption went OK, I was using disk for some while but yesterday I got tired with that windows info every time I plugged it in saying that disk needs to be formatted.
I remembered that there was an solution for that in faq session. I thought I remember the procedure correctly but unfortunately I though wrong. I did the following: right click on desktop computer > manage > disk manage > and here instead of clicking "change drive letter and paths" I clicked remove volume which was the option below. Now I can't access to disk.
Then I assigned new letter to disk with windows creator but didn't use format option with it but still no effect.
This causes me almost heart attack because on that disk I have my family pictures and videos from many years. Is it possible to recover it?
Oct 20, 2016 at 4:06 PM
Have you tried mounting the volume in VeraCrypt using the option of embedded backup header if available?
Oct 20, 2016 at 5:09 PM
I tried option "backup volume header" but I got some error. I did "restore volume header" and I got info that it was succesufly done but I can't mount it. I still got error:

Operation failed due to one or more of the following:
  • Incorrect password
  • Incorrect Volume Pim number
  • Incorrect PRF (hash)
  • Not a valid volume
Oct 20, 2016 at 7:24 PM
How did you restore the volume header? From the embedded backup header or did you previously make an external header backup file?

If you were unable to mount the volume using the embedded backup header, restoring the volume header using the embedded backup header is not going to resolve the issue and I am not sure where VeraCrypt would have wrote the restored header on the disk since you removed the volume from Disk Management.
Oct 24, 2016 at 4:04 PM
I didn't make an external header backup to my usb disk. I used option "from embedded backup".
Like I said before, after that I got info that operation completed with success but it didn't make effect accessing usb disk.

Problem is still unsolved. I can't access data on my disk. When I removed (by accident) volume from disk manager I destroyed all encrypted data on disk? Is it possible to restore that volume and get access to data?