This project has moved and is read-only. For the latest updates, please go here.

during the pretest the pre-boot authentication password I entered is incorrect

Topics: Technical Issues
Oct 17, 2016 at 11:37 AM
Edited Oct 17, 2016 at 12:10 PM
I'm sure the password is correct. I tried it twice with new keyfiles, to rule out data corruption. Num- and Caps Lock states were correct.

Since I use the DE keyboard layout, I checked how VeraCrypt creates the password. It allready transforms my password to US layout (the reason, why users of other than US layouts can't easily automount aditional drives with the pre-boot authentication password, because on non system drives VeraCrypt does not transfrom the password), so this should not be an issue. For fun I tried typing the US layout password with an DE layout, just to check if maybe my PC does use one on startup, but there was no change in the message.

I used Truecrypt many times before to encrypt my system partition, until I switched to new hardware. With VeraCrypt its my first time since it did not have UEFI support until recently.

Is there any other reason why this does not work?

Edit: I tried again with an simple password, containing only letters and numbers found on both DE and US layout at the same location and it worked. This must have something to do with the differences of the two but I don't know how and why.
With the complex password:
On creation I type the chosen password on my keybord just as I would in an DE-layout environment. When pressing "show password" the password is shown, translated in US-layout.
On startup, I type the chosen password on my keybord just as I would in an DE-layout environment. This way the coresponding US keys are used and I should be granted exess, but it does not work.
Then I tried typing the US-Keybord translated password as I would, in DE-kayout environment, just to check if somehow I got the DE-layout on statup, but it does not work either.