This project has moved and is read-only. For the latest updates, please go here.

Failure to mount device/MacFuse compatibility issues

Topics: Technical Issues
Oct 12, 2016 at 12:05 PM

I have been passed an encrypted SSD which I have attempted to mount using the latest VeraCrypt and OSXFuse with the MacFuse compatibility layer as instructed on the download page.

I have tried mounting the device (/dev/rdisk2) and also the 'sub' device (/dev/rdisk2s1) on the SDD with the default settings and the password provided. What I get is the following:

Operation failed due to one of more of the following:
  • Incorrect password
  • Incorrect Volume PIM number
  • Incorrect PRF (hash).
  • Not a valid volume
After this failure I attempted to sshfs (homebrew/fuse/sshfs previously installed) to one of our machines which now raises this error:

mount_osxfuse: the OSXFUSE file system is not available (255)
fuse: failed to mount file system: No such file or directory

To try and tidy things up I uninstalled the OSXFuse pkg via the system preferences panel. But my previous sshfs install is now totally broken:

dyld: Library not loaded: /usr/local/lib/libosxfuse_i64.2.dylib
Referenced from: /usr/local/bin/sshfs
Reason: image not found
Trace/BPT trap: 5

So not only does VeraCrypt not mount the SSD, but the advised install process has also broken my sshfs setup, which I use for software development. SNAFU! Literally hours wasted on this already.

Ideally VeraCrypt would be able to use the brew version of OSXFuse which does not support the MacFuse compatibility, as this is legacy code (

Any help or advice would be much appreciated.


Nathan Johnson
Oct 13, 2016 at 11:18 PM
Hi Nathan,

VeraCrypt doesn't modify libraries installed on the system so your issue was caused by official OSXFuse installer who broke brew version of OSXFuse.

I have published a new installer for 1.19-BETA3 for OSX that removes dependency to MACFuse compatibility layer. You can get it at:
Can you please check that it works now correctly on your system?

Oct 29, 2016 at 5:22 PM
Edited Oct 29, 2016 at 5:46 PM
Hi - I seem to be having a similar issue with MacFuse despite using the 1.19 version that was made available on the 17th. I have tried creating both an encrypted external HD as well as a container on my desktop and at the conclusion of the formatting, I get this error: "the OSXFUSE file system is not available (-1)."

I just installed VeraCrypt 1.19 (had not had a prior version on this machine - macbook pro, osx el capitan 10.11.6) and the most recent version of FUSE (3.5.3) with the MacFUSE compatibility layer.

Any hints?