This project has moved and is read-only. For the latest updates, please go here.

Mac os x - hdiutil: attach failed - no mountable file systems

Topics: Technical Issues
Jul 25, 2016 at 4:37 PM
Edited Jul 25, 2016 at 4:52 PM
Hello people,
few days ago I updates my macbook air to 10.9.5 maverics just slight update (security bla-bla) from 10.9.2 or 10.9.3 forgot already.. after this today tried to mount my truecrypt entirely encrypted disk with hidden partition and after entering the right password I'm getting

hdiutil: attach failed - no mountable file systems

In the syslog i get:
kernel[0]: disk3s1: I/O error.
VeraCrypt::File::ReadAt:306: Input/output error: /dev/rdisk3s1
disk5: 0xc005 (UNDEFINED).
diskarbitrationd[17]: unable to probe /dev/disk5 (status code 0xFFFFFFFC).
Is my disk fault and is it safe to run Repair disk from the repair utility in MacOS to fix eventual problems... or the problem is somewhere else.

What I did: Tried with Truecrypt 7.1, 7.1a with the latest VeraCrypt, I had installed paragon, removed it, installed again Fuse For OS (OSXFUSE) 2.8.3 again...

I don't remember using my disk after the update honestly, can be some shitty OS X update cosing or not... need your opinion to figure out what to do. Using it with Truecrypt for the past 8 monts...

EDIT: Also attached disk on windows (10) machine, mounted but cannot access the mounted disk because i think is HFS+ formatted.

I really need your help, thank you very much in advance!!!