This project has moved and is read-only. For the latest updates, please go here.

TC .bat doesn't work with VC

Topics: Technical Issues
Jul 13, 2016 at 11:26 AM

I mount a truecrypt-container (named LW_V) with this Batchfile:
TrueCrypt.exe /lV /q /a /c n /m /v LW_V
and dismount it with: TrueCrypt.exe /dV /q /f

So I tried the same with VeraCrypt and a VeraCrypt-Container:
VeraCrypt.exe /lV /q /a /c n /m /v LW_V

It doesn't work!

Any ideas?
Jul 13, 2016 at 11:51 AM
Doesn't work how? If the container is still in truecrypt format, I guess you'll have to add the truecrypt compatibility tag (/tc).
Jul 13, 2016 at 12:09 PM
So I tried the same with VeraCrypt and a VeraCrypt-Container:
VeraCrypt.exe /lV /q /a /c n /m /v LW_V
Jul 13, 2016 at 1:08 PM
Try a space between /l and V.
/a is redundant if /q and /v are specified.
/m has no meaning without a relevant following parameter.
Jul 13, 2016 at 1:17 PM
That way?
VeraCrypt.exe /l V /q /a /c n /m /v LW_V

Same :(
Jul 13, 2016 at 1:22 PM
Is Veracrypt in your PATH?
Jul 13, 2016 at 1:26 PM
Yes, its all in a folder on an usb-stick.
I'm using these parameters for years with truecrypt ...
Jul 13, 2016 at 1:39 PM
You're using Veracrypt now! Why assume it works exactly the same? The functionality has been greatly expanded.

Read the documentation, and follow it precisely:

Perhaps it's the meaningless /m option that's the problem.

"It doesn't work." What happens? Any error messages?
Jul 13, 2016 at 1:50 PM
Jul 14, 2016 at 10:22 PM
Of course you get that. From documentation of /m: "It must be followed by a parameter which can have one of the values indicated below." Either specify mount option, or remove /m parameter, as Adrian suggested. Read the documentation!
Jul 15, 2016 at 8:10 AM
I'm not familiar with parameters, so the documentation doesn't helps me.
Jul 15, 2016 at 9:48 AM
Documentation is there to make you familiar with them ;-) So you just cluelessly copied the long string of parameters from somewhere? I get it, you don't want to read, but why don't you listen at least? If you have no problem with doing something without knowing what you are doing, remove the /m parameter and you will get exactly what you wanted:

VeraCrypt.exe /l V /q /a /c n /v LW_V

This had been answered already.
Jul 15, 2016 at 12:46 PM
Edited Jul 15, 2016 at 12:47 PM
Yes, I just copied the string - without knowing the meaning of the parameters.
My English is very bad, so forgive me. :-)

Now, I copied your string and it works fine for me.
Thanks a lot!
This had been answered already.
Maybe, but I didn't understand it.
Compared to TrueCrypt the mounting of VeraCrypt is very slow.
Jul 15, 2016 at 1:53 PM
On a slow computer the mounting is noticeably slower, because it is much more secure than truecrypt was. You can speed the mounting up either by selecting encryption algorithm, so mounting takes only 3 seconds on my 10 years old cpu, or by picking up a PIM number. If you will use PIM value 1, you will lesser the security, but the mounting speed will be about the same as truecrypt, yet it will be more secure than truecrypt.

example with PIM 1:
VeraCrypt.exe /l V /q /a /c n /pim 1 /v LW_V

Note: it won't work on your existing container, you will have to change the PIM to 1 first in the password changing dialog. PIM can be any number, but you will have to remember it along with your password - correct password with wrong PIM does not work.

And don't worry about you English, mine is probably even worse ;-) You can always use google translator...
Jul 15, 2016 at 2:19 PM
That sounds interesting, thx. If I will have a little bit more time, I'll
familiarize myself more with the possibilities of VC. Maybe, when TC dies and is no longer running on current operating systems,
there would be some people tranlating the manuell in other languages.
Google translater is a pain for technical things :D