This project has moved. For the latest updates, please go here.

Corrupted Veracrypt partition?

Topics: Technical Issues
Jul 6, 2016 at 6:40 PM
I believe a power outage may have corrupted an encrypted USB drive I had mounted. The entire drive/volume was encrypted and when it failed to mount I noticed it was a raw disk with no partitions.

The mount with backup embedded volume header seems to work and mounts with the correct password but the NTFS system is missing. I did make a file copy backup of the embedded header before this happened and it appears to work but the same issue of no NTFS system.

I have ran at least 6 NTFS file recovery programs that work on "Virtual Disks" and nothing has been recoverable.

I suspect the problem I am having is that I need to re-create the partition at a specific sector and mount it from that point but I have no idea where that partition/sector would start in order to re-create it. Does this sound like my problem or should I still be able to recover/read data if the raw volume mounts in Veracrypt?
Jul 6, 2016 at 6:54 PM
Please provide the six recover software have you tried on your mounted volume. Perhaps there is another software that could be recommended.
Jul 6, 2016 at 7:40 PM
I remember having a very similar issue 3 or 4 years ago with TrueCrypt and I found a program called "TestCrypt" that was able to scan a drive for Truecrypt Partitions. It found my missing Truecrypt partition and I was able to recover successfully. There doesn't appear to be a similar program for Veracrypt? I did try TestCrypt on this drive but it didn't find anything so I assume it can't find Veracrypt partitions.

Here is a list of recovery software I didn't have much luck with. I still suspect the issue is that I'm not mounting the partition anymore but the raw drive so it's probably not starting at the correct place? If anyone thinks this shouldn't be an issue let me know.

GetDataBack NTFS - Found no files/structure
Active File/Partition Recovery - Found no files/structure
Easeus Data Recovery - Found no files/structure
Recuva - Didn't work on virtual disk
Testdisk - Partition sector doesn't have the endmark 0xAA55
Diskinternals - Found no files/structure
Wise Data Recovery - Found no files/structure
Puran File Recovery - Found no files/structure
Stellar Pheonix - Found no files/structure
Jul 6, 2016 at 9:23 PM
Try the following:
  1. R-Studio
  2. File Scavenger
  3. Photorec