This project has moved and is read-only. For the latest updates, please go here.

Installation problem on ubuntu

Topics: Technical Issues
Jun 7, 2016 at 9:02 AM
Edited Jun 7, 2016 at 2:09 PM
I have tried several times to install Veracrypt 1.17 (GUI, 64bit) on a clean install of ubuntu 16.04 (64 bit). After installation, I am not able to open the Veracrypt GUI. Veracrypt-icon appears on the left-hand-side/Unity bar. And from terminal, it seems to function ( § veracrypt -help, etc), but I am not familiar with terminal mode. I have re-installed the OS and Veracrypt, several times, and also tried on ubuntu 14.04, but now with the same problem.
Earlier I have installed different versions of Veracrypt on systems like ubuntu 14.04, netrunner, and Windows7, and it always have functioned very well.
-Can anyone help?
Jun 8, 2016 at 8:53 AM
Edited Jun 8, 2016 at 8:54 AM
Have you tried the latest beta? There might have been some problem on linux with 1.17, try latest 1.18 beta, which you can get from sourceforge. This works for me (I'm on mint, which is a close relative to ubuntu):
mint@mint ~/Downloads $ wget
mint@mint ~/Downloads $ tar -xvf veracrypt-1.18-BETA-setup.tar.bz2
mint@mint ~/Downloads $ ./veracrypt-1.18-BETA2-setup-gui-x86
mint@mint ~/Downloads $ veracrypt&
You will probably need to insert sudo before veracrypt setup. Not sure why, but files from sourceforge are retrieved via plain http, which is a security risk.
Jun 8, 2016 at 9:33 PM
Thank you for the suggestion. I have just tried the 1.18 BETA on my desktop ubuntu 16.04, and it didn't work. I also rolled ubuntu back to 14.04, and tried the BETA, but with the same result. At the same time, I had no problem installing Veracrypt (tried the BETA-version) on my old ubuntu 14.04-laptop.
I have spoiled 3 evenings on this now, so I think I'm giving up. Thanks anyway !
Jun 15, 2016 at 9:12 PM
By accident, I think I finally found the explanation. When I disconnected my second display (which was plugged in, but not turned on), the Veracrypt GUI appeared and came to live. Every time the display is re-connected, the Veracrypt GUI freezes. Disconnecting the second display, I have no installation problem. Most likely there is an issue in Ubuntu with the drivers for my graphics card (AMD Radeon R7 200).
Jun 17, 2016 at 5:07 PM
Edited Jun 17, 2016 at 5:07 PM
With ubuntu 16.04 there's another issue, which can be resolved by installing dm-setup (probably not relevant to your problem though):
sudo apt-get install dmsetup