This project has moved and is read-only. For the latest updates, please go here.

size limits for hidden containers

Topics: Technical Issues, Users Discussion
Jun 6, 2016 at 4:14 AM
Edited Jun 6, 2016 at 4:15 AM
I seem to be having an issue with size limits on hidden containers. I have used truecrypt for years, and am updating to the latest veracrypt. I created a 10gb container, FAT formatted, and then created a 4GB hidden container within it. I filled the hidden container with about 3GB of misc. files, then remounted the outer container (with write protection) and tried copying a bunch of files into it. It ran out of space after only 1.7 GB.

I tried a different way. I created a 12GB container, put about 5GB worth of stuff in it, and then went to create the hidden container, but it warned me that there was not enough space. I then deleted about 2 GB from the outer container, leaving me with about 9GB unused. I then went to create the hidden container, and it informed me that the largest container size was 271MB.

Using the hidden containers seems to take up a lot of dead space. Am I doing this correctly? I read through the documentation and do not see anything about the size limitations.
Jun 6, 2016 at 5:14 AM
Well, I have managed to solve my own issue, so I thought to let others know if they run into the same issue. You have to be careful with the block sizes when formatting the containers. If you use the default, the block sizes are large, and if you write a bunch of smaller files, you will waste a lot of space. I set the block size to 2 kb, then repeated my experiment above. After creating the 12Gb container, and formatting, and copying 1.7 GB of files into it, it let me do the hidden container with up to 10.1 Gb. Much better.
Jun 6, 2016 at 1:04 PM
Well, it started happening again! I did two containers, testing the limits, and both worked with the smaller block size. I tried a third one, and this one gives me the "not enough room" message even though there are over 8 Gb free. Any ideas anyone?
Jun 7, 2016 at 2:50 AM
OK, now it gets even stranger. I restarted the computer, then tried again in Veracrypt. I even tried making the outer container larger, and after copying the files into the outer container, it still said that there was insufficient room for the hidden container. I then tried the exact same things in TrueCrypt, and it worked.

Weirder and Weirder.
Jun 7, 2016 at 10:18 AM
Even more weird stuff. I tried the same thing on my windows tablet. It worked fine on there. Something with this crap laptop (last time I buy a Toshiba).
Jun 7, 2016 at 4:23 PM
It appears that you are experiencing fragmentation when writing many small files to the outer and hidden volumes.

Try copying in smaller batches when using Windows Explorer or use RoboCopy from Microsoft to perform the copy of the files.

Although, it does not make sense that this fragmentation only occurs with VeraCrypt file containers and not TrueCrypt since VeraCrypt is created from the TrueCrypt source code.