This project has moved and is read-only. For the latest updates, please go here.

Veracrypt -- Can't get it to mount on OSX El Capitan

Topics: Technical Issues
May 30, 2016 at 5:05 AM
I've got veracrypt within OSX El Capitan 10.11.5 and within a virtual box container running Arch Linux. Everything seems to work within the Virtual Box Arch Install. I can create a standard veracrypt container within Mac, however when I go to mount the file, I get the popup stating VeraCrypt requires OSXFuse 2.3 or later with MacFuse compatibility layer installer. I've installed Fuse for OSX 3.3.2 with the compatibility layer installed and tried rebooting several times, however I still get this error message. Does Veracrypt mount volumes with El Capitan?
Jun 6, 2016 at 12:18 AM
Edited Jun 6, 2016 at 12:27 AM
Hi Keydogg,

I had a similar issue and I am currently running an IMAC with OS X El Capitan 10.11.5 also. I have an external hard drive with a Veracrypt container. I submitted a post (#465) and later found out that there was a problem with the Veracrypt Version that I had.

I reviewed another post (item # 268 and item #394) , and found the answer to my own question which solved the problem. Another user has already reported this in the issues tracker (https://veracrypt.codeplex.com/workitem/394).

Per documentation provided in another post by Mounir Idrassi, coordinator, who specializes in consulting on cryptography and IT security under the umbrella of IDRIX, he has implemented a fix and uploaded an installer for version 1.18-BETA, a new version of Veracrypt that solves this problem.

You can get it on this following page:

https://sourceforge.net/projects/veracrypt/files/VeraCrypt%20Nightly%20Builds

HOWEVER, DO NOT DOWNLOAD WHAT THE WEBSITE STATES IS THE LATEST VERSION ON TOP: THIS IS NOT CORRECT. THE FILES THAT WORKED ARE IN THE DIRECT LINKS BELOW:

The item that worked for me was 12th down this list which is the following (DIRECT LINK)

https://sourceforge.net/projects/veracrypt/files/VeraCrypt%20Nightly%20Builds/VeraCrypt_1.18-BETA.dmg/download

Another version that is even more updated is as follows (DIRECT LINK)

https://sourceforge.net/projects/veracrypt/files/VeraCrypt%20Nightly%20Builds/VeraCrypt_1.18-BETA1-DEBUG.dmg/download


I deleted the older version of Veracrypt and replaced it with one of the above and I was able to mount my volumes without getting the message.

I hope this helps.

ip5.
Jun 13, 2016 at 5:26 AM
ip5 -- Thanks for the links. I can verify that the following link work for me:

https://sourceforge.net/projects/veracrypt/files/VeraCrypt%20Nightly%20Builds/VeraCrypt_1.18-BETA1-DEBUG.dmg/download

Thank your very much. Now off to experiment with things.