This project has moved and is read-only. For the latest updates, please go here.

Still issues with System Favorites not mounted with Windows 10

Topics: Technical Issues
Apr 4, 2016 at 9:04 AM
Edited Apr 4, 2016 at 9:15 AM
First of all I have exact the same problems bevore with Truecrypt 7.1a and update to Veracrypt 1.17 because I read in the changelog that version 1.12 "Fix system favorites not always mounting after cold start." Unfortuantely the problem still exist in the 1.17:

I first install Veracrypt and encrypt the system partition in Windows 10 x64. Then I mount one or two encrypted partitions and define them as system favorites (drive letter d and e). Till this everything worked fine.
But then I plugged in an USB stick bevore booting windows and the stick gets the drive d and no system favorites are mounted. From this moment on it is impossible to get the system favorites back automatically mounted also when the USB stick is not conected on next windows start. I can delete them and define them new nothing gets back the initital working bevore USB stick was connected. They only worked again when Windows is not "cold" started but restarted! Bevore I plugged in the Usb stick the system favorites worked with "cold" and "hot" start of windows. With Truecrypt the behavour was the same. The only way to get the system favorites back fully working was to unencrypt the system partition und encrypt new like I did when changing from Truecrypt to Veracrypt.

I've made two screenshots from the actual system one with "cold" start not working and one with "hot" start working:

With Windows 7 and Truecrypt I have never had this problem..

Sorry for the bad english I'm a native german..
Apr 4, 2016 at 3:52 PM
Have you disabled Windows feature called Fast Startup?
Marked as answer by ronker on 4/4/2016 at 9:32 AM
Apr 4, 2016 at 5:31 PM
Edited Apr 4, 2016 at 8:12 PM
This solves the problem! Big thanks!

I've read from the "fast startup" issue with veracrypt but I didn't realize that it is an issue with the "cold start". I thought this is only a problem when you do "suspend to disk" ...

Even worked with three additional usb sticks connected. They use the drive letters a,b and f so both system favorites are mounted with them.