This project has moved. For the latest updates, please go here.

VeryCrypt 1.17 Background Task writes RAM full

Topics: Technical Issues
Feb 29, 2016 at 5:55 PM
Hello colleagues,

a few days ago I updated my VeraCrypt 1.16Beta to 1.17(stable) version.

Since that time, after the start of VeraCrypt and the running Background Task in the Taskbar the program is eating my RAM until system is unusable.
As i thought the problem maybe appears because I change from beta to stable, i uninstalled VeraCrypt completely. I restarted my Windows 7 64bit and i installed 1.17(stable) again. The problem returned.
I started to check the VeraCrypt Settings and found the option of the Background Task. I deactivated it. I restarted. I mounted my volumes and closed VeraCrypt. I used my mounted volumes. Everything was fine. Nothing was eating my RAM. So I identified the Background Task as reason of the problem. But Why is the question.
What did changed from 1.16 to 1.17 with the Background Task Service of VeraCrypt?

I personally not very depending on the Background Task but it would be nice to use all the functions of VeraCrypt without inconvenience.

Does anyone else is suffering this problem?
Feb 29, 2016 at 7:10 PM
How much memory do you have on your system?

How long does it take to consume the memory with the VeraCrypt process?

When you look at the Windows Task Manager and scroll down to VeraCrypt.exe, how much memory is it using on your system?
Feb 29, 2016 at 8:42 PM
Hello Enigma2Illusion,

thank you for your reply.
My System has 4GB RAM.
The VeraCrypt application itself just uses 5MB RAM without the running Background Task Service.

If the Background Task is running it doesn't matter if 20, 30, 50 or 70% of the RAM is in use. The Background Task takes step by step all the rest of the free RAM. If more RAM is available it just takes a few minutes longer until the Background Task has brought the RAM usage to 99-100%.
I would say round about 10 minutes after the Background Task started the system RAM is completely in use.
Feb 29, 2016 at 10:00 PM
Hello nethstarcorp,

There must be something else causing this behavior since my Win7 Pro 64-bit system does not experience this issue when running 1.18 Beta 2 version of VeraCrypt and with background task enabled. Running all day with volumes mounted, my VeraCrypt.exe shows-up in Task Manager with ~ 13 MB of memory usage.

I ran on 1.17 for a few days before I went to 1.18 Beta 1 and then Beta 2.

Do you want to try 1.18 Beta 2?

https://sourceforge.net/p/veracrypt/discussion/technical/thread/9e760c29/

https://sourceforge.net/projects/veracrypt/files/VeraCrypt%20Nightly%20Builds/

What AntiVirus are you running? There must be something that is causing VeraCrypt to keep consuming memory.
Mar 4, 2016 at 7:17 AM
This happens here too. VC 1.17 is using a few GB...
Coordinator
Mar 4, 2016 at 7:58 AM
Edited Mar 4, 2016 at 8:02 AM
Since this doesn't happen on our side, we will need more details about the specifics of your configuration that triggers this.

Few more questions:
  • Are your using system encryption? If yes, are you using system favorites?
  • Can you please post a screenshot of the VeraCrypt Preferences dialog?
  • Can you please post a screenshot of VeraCrypt entries in Winows Task Manager after enabling the display of the command line and checking the option to display process for all users? How many VeraCrypt processes do you see?
  • Can you please download and run the Microsoft tool Process Explorer (https://technet.microsoft.com/en-us/sysinternals/processexplorer.aspx) and post screenshots of VeraCrypt entries in it, including of course the performance and performance graph dialogs?
Below you will find such screenshot taken on a Windows 7 system that I use daily and where the background task is activated. As you can see, VeraCrypt takes 6.5 MB of private memory.

Thank you in advance for your help.

Task Manager Entry:
TaskManager

Process Explorer Entry:
Image

Process Explorer Performances Dialog:
Image

Process Explorer Performances Graph:
Image

VeraCrypt Preferences:
Image
Mar 4, 2016 at 4:38 PM
  • system encryption - no
  • preferences - default settings (same as your screenshot, except background task disabled)
Memory is released after dismounting
Mar 4, 2016 at 11:04 PM
command line - "C:\Program Files\VeraCrypt\VeraCrypt.exe" /v "file_path"
Coordinator
Mar 5, 2016 at 12:22 AM
@bugmenot2: you don't use the background task, so your issue is different from the one of the original poster. Since the memory is released after dismounting, you seem to be affected by the Windows cache issue that is discussed here and here. You will find on those links the fix for such problem.

@nethstarcorp: can you please answer the questions of my previous post? Details of your situation will be helpful.
Mar 5, 2016 at 12:56 AM
@idrassi: I wasn't writing data to volume. Read operations only. Memory usage seems to increase over time.
Mar 5, 2016 at 10:19 AM
Hello colleagues,

sorry that you had to be patient for my reply.

I was busy with tests in this issue in the last days and i found a solution for my problem, which is actually very simple. I made a registry clean with CCleaner and made during two days several shutdowns and restarts. After that yesterday i activated the Background task again it worked probably again. Till now no problems.
Maybe the problem was of an incorrect registry clean up during the upgrading process to the 1.17 version.

I'm also not using system encryption.
Mar 5, 2016 at 7:23 PM
bugmenot2 and nethstarcorp,

Did you have both VeraCrypt Background Task and in Windows login section option Start VeraCrypt Background Task disabled or only disabled VeraCrypt Background Task?

The common settings for both of you seems to be disabling VeraCrypt Background Task caused the issue.
Mar 5, 2016 at 9:22 PM
@Enigma2Illusion

Here are some additional details:
  • VeraCrypt Background Task - Enabled
  • Start VeraCrypt Background Task (upon logon) - Disabled
Jul 22, 2016 at 11:57 PM
Has a full solution been found for this issue? I'm having the same problem. I'm needing to use the background task to auto mount favorites. However, it consumes all of the RAM. Uninstalled and re-installed multiple times - no change. Removed all favorites - no change. Removed favorites and config files from appdata - no change. Unchecked most everything from preferences - no change. As noted above by user nethstarcorp cleaned the registry with CCleaner and rebooted multiple times - no change.

It's consuming approximately 1-2 MB per second until it finally uses up all the RAM.

Any help would be appreciated.

VeraCrypt 1.17
OS Name Windows 10 Professional
OS Version 10.0 (Build 10586)
Total Physical Memory 3972 MB
Available Physical Memory 2212 MB
Coordinator
Jul 24, 2016 at 7:40 AM
Did you try with the latest 1.18-BETA available at https://sourceforge.net/projects/veracrypt/files/VeraCrypt%20Nightly%20Builds/? Many fixes done since last time?

In case the issue persists, can you please post screenshots of Process Explorer tool as I explained in my March 4th post above?

Thank you.
Jul 26, 2016 at 2:31 AM
ver1.18 installed. Better performance, however, still consumes memory (all be it slower).

Codeplex image upload makes no sense. So, all requested screenshots as well as previous diagnostics uploaded to a shared Google Drive at this link.


https://drive.google.com/open?id=0BxGCx6rerPLoenlrOWhlTjgtbkk