This project has moved. For the latest updates, please go here.

How to install Fedora on Veracrypt

Topics: Technical Issues
Feb 14, 2016 at 12:18 PM
Edited Feb 14, 2016 at 12:18 PM
Hello,

I want to install Fedora on Veracrypt but I can not , can you help me if you like it to install ? The Fedora link on the official page of Veracrypt gives me a 404 .
Fedora/Redhat RPM packages by user DrLinux (rene@maxef.nl):
https://copr-be.cloud.fedoraproject.org/results/drlinux/VeraCrypt/
Feb 14, 2016 at 2:33 PM
Edited Feb 14, 2016 at 5:36 PM
Here is the error message I encountered when I install Fedora 23.
[root@linux a]# /home/a/Téléchargements/veracrypt-1.17-setup-gui-x64
Verifying archive integrity... All good.
Uncompressing VeraCrypt 1.17 Installer..
Warning: Missing charsets in String to FontSet conversion
Warning: Missing charsets in String to FontSet conversion
Warning: Missing charsets in String to FontSet conversion
KUniqueApplication: Cannot find the D-Bus session server:  "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." 

KUniqueApplication: Pipe closed unexpectedly. 
Coordinator
Feb 18, 2016 at 7:48 AM
Hi,

To solve the issue of the graphical installer under Fedora 23, you have to install the packages xterm and xmessage using the command:
dnf install xterm xmessage
This way, you will have the usual UI for the installer.

You can also install VeraCrypt using only the command line by using the following steps:
  • Decompress the installer embedded with the file: ./veracrypt-1.17-setup-gui-x64 --noexec --target
  • The above command will create a file called veracrypt_install_gui_x64.sh. Run it directly: ./veracrypt_install_gui_x64.sh
  • Select option 1 and type ENTER
  • Accept the license by typing yes and hit ENTER
  • The installation will proceed.
Feb 20, 2016 at 1:57 AM
Thank you, it works! I finally chose Debian 8.3 with your solution. A big thank you!