This project has moved and is read-only. For the latest updates, please go here.

2nd hidden drive letter exists, and appears after dismount and eject

Topics: Technical Issues
Jan 26, 2016 at 1:18 AM
Windows 7 Enterprise, VeraCrypt 1.16, 64 bit

I mount two type "Normal" volumes using Mount Favorite Volumes with one password for both and the temporarily cache PW setting.

USB stick is drive W. Mounted drives show, as desired, as R: and Z:

Looking at Windows Explorer, everything looks correct (only R: and Z: show, in addition to my physical drives).

Dismount and R: and Z: disappear.
Eject and E: and F: appear <--- I never saw this with TrueCrypt.

Those phantom E and F drives don't actually exist and cause Windows to report that the Recycle Bin for those drives is corrupt (even after a reboot makes them disappear.

Once I was investigating I found that with my volumes mounted I could open a command prompt and go to the E and F drives, even though they didn't show in Explorer, and they were actually the same as my mounted R and Z drives.

Is there a fix for this?

Thank you!
Jan 26, 2016 at 4:34 AM

The issue can occur when using both TrueCrypt and VeraCrypt volumes or if you used version 1.15 in the past which has this problem.

There may be something in the registry causing the issue.

First upgrade to latest version 1.16 or higher. I include this statement for the benefit of other users reading this thread.

With the all volumes dismounted, perform the following.

Using a modified version of Idrassi's instructions:
Check the registry key "HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices" using regedit. Scroll down and you'll find entries starting with "\DosDevices\" which indicate the drive letters that are taken by the system. Before mounting any volume, double click on each one and remove the ones contains the name "VeraCrypt" and "TrueCrypt".
Also, there are other entries whose name start with "#{" and "\??\Volume{": double click on each one of them and remove the ones whose data value contains the name "VeraCrypt" and "TrueCrypt".
Reboot PC.

Kind Regards.
Marked as answer by LibertySWE on 1/30/2016 at 8:42 AM
Jan 30, 2016 at 4:42 PM
This worked perfectly on both of my affected systems.

Thank you!
Jan 31, 2016 at 2:10 PM
Edited Jan 31, 2016 at 2:11 PM
I have the same problem. The fix you mentioned didn't help me. I still have lingering volumes. Worse, now I cannot mount it again on the same letter. I very quickly run out of letters to mount it to (I use the auto-dismount after n-minutes feature).

I'm on Win 10 Pro x64 and VC v1.16 x64 (7 October 2015).
Jan 31, 2016 at 4:22 PM

Does the issue occur even when you manually dismount the volumes or only when auto-dismount after N minutes?

Another forum user said that he used the mountvol /r at a command line. Open the command window with administrator privileges.

Dismount all volumes and I would temporarily disconnect any encrypted external drives from the PC.

Open a command window as Administrator to perform the mountvol.exe /r command.

Reboot PC.

Kind Regards.
Feb 4, 2016 at 10:51 AM
It doesn't matter whether I manually dismount or have the container auto-dismounted.

I tried the "Mountvol.exe /R" tip. It doesn't help. The volume is still unavailable.

Obviously, rebooting helps. But, on mounting and dismounting any VC container the problem returns. GRRRRRRRRRR
Feb 4, 2016 at 4:45 PM
If you are willing to use the DriveCleanup utility below to remove all currently non present USB Storage Devices, Disks, CDROMs, Floppies, Storage Volumes and WPD devices from the device tree. Furthermore it removes orphaned registry items related to these device types.

I request you use version 0.9.0 since I have not tested 1.2.0 version that was recently released. The 1.1 version did not wipe existing devices from the registry.

Create a directory and unzip the files into the directory.
Start a command line prompt as Administrator.
In the command window, change into the directory where you unzipped the files. If you are using 64-bit Windows OS, change into x64 subdirectory.
Dismount all volumes.

Use the following command to see what the DriveCleanup utility will remove from the registry:

drivecleanup -T

To remove items the registry:


Reboot PC after running utility.

Any USB that was not currently connected to your PC will be install again by Windows and you may have to manually reassign the drive letters in Windows Disk Management if you had certain drive letters for an external hard drive or thumbdrives.

I have performed this numerous times on my Win 7 Pro 64-bit Windows system to remove all registry entries including valid devices due to tests with file containers.

If anyone knows of a better free utility, please post it.
Feb 4, 2016 at 9:55 PM
Edited Feb 4, 2016 at 10:43 PM
I ran the tool.
I restarted.
I mounted a container on drive letter M:.
I dismounted the container with the 'Dismount all' menu option.
The drive letter is still occupied. :'(

Would it help if I go to v1.17 beta?

I found the problem!
If I do the 'Dismount all' from the tray icon, VC FAILS to release the drive letter.
If I do 'Dismount' or 'Dismount All' from the GUI, VC SUCCEEDS to release the drive letter.

idrassi, could you please fix this?
Feb 5, 2016 at 3:00 AM
Edited Feb 5, 2016 at 3:00 AM
Great job SHBouwhuis finding the issue with the Dismount All via the VeraCrypt tray icon.

So the issue was never with the dismount after N minutes? I ask just in case there are two bugs. :-)
Feb 5, 2016 at 8:29 AM
Edited Feb 5, 2016 at 8:33 AM
Ok, now I'm confused.
Everything fails to release the drive letters now.

Maybe after it fails the first time, every other attempt to release the drive letter also fails?

Ok, maybe I have found something.

When I look in a 32-bit application, the drive letters are stuck.
When I then double click a *.hc container the GUI opens and the drive letters are missing.
I cannot mount the container on any of the 'missing' drive letters.

When I look in a 64-bit application, the drive letters are free.
When I then double click a *.hc container the GUI opens and the drive letters are there.
I can mount the container on any of the drive letters.

So, maybe it's a 32-bit issue? There is clearly a difference between opening the GUI from an x86 vs x64 application.
Feb 5, 2016 at 3:49 PM
Are you running VeraCrypt in portable mode? Did you install VeraCrypt?

The installer will detect the 32/64-bit OS and install/rename the appropriate executable for the OS.
Feb 5, 2016 at 4:11 PM
Edited Feb 5, 2016 at 4:59 PM
I used the installer.
ProcessHacker states that the 64-bit version of VeraCrypt is running. It is started with:
"C:\Utilities\VeraCrypt\VeraCrypt.exe" /q preferences /a logon

I noticed the following:
When I double click a *.hc file from within a x86 application, a NEW VeraCrypt.exe is added as a process.
The titlebar states "VeraCrypt (Administrator)"

When I double click a *.hc file from within a x64 application, NO new VeraCrypt.exe is added as a process.
The titlebar states "VeraCrypt"
Feb 5, 2016 at 10:24 PM
Can you give examples of third party 32/64-bit applications you are using to open file containers to launch VeraCrypt?

I am not sure VeraCrypt was design for this purpose.
Feb 5, 2016 at 10:26 PM
Edited Feb 11, 2016 at 9:37 PM
x64 : Windows Explorer
x86 : XYplorer

I've used XYplorer for years now with TrueCrypt and for a year or so(?) with VeraCrypt on Windows 7 x64.
Only when I switched to Windows 10 did this problem start.

Mr Idrassi, do you have any idea how to fix this?
Should I revert to a lower version? (v1.14 for instance?)
Feb 21, 2016 at 9:01 AM
Edited Feb 21, 2016 at 9:04 AM

I recently changed computer to Acer V3-574G-79AB with preinstalled Win 8.1/64. I divided internal disk into two partitions. I left system partition (C:) intact while another one was formatted using TrueCrypt (D:).

From the very beginning I had problems to mount encrypted partition and external USB drives, also formatted under TrueCrypt 7.1a.

The system usually displays WARNING message stating the THESE PARTITIONS WERE IN USE and warns that system may be unstable. It also recommends to close all applications that may be using these partitions as well. The problem is I am unable to find any application using these partitions (except Win).

I also observed flw behaviours:
  1. The letter D is visble in Total Commander and system usually assigns letter E: for encrypted partition.
  2. If E: is mounted as soon as possible after logon the entire mount runs without problem (no warnings).
  3. Mounting external drive(s) usually triggers the warning window mentioned above.
  4. Once after dismount of E: I had to use backup header.
  5. One of my disks formatted under TrueCrypt is divided into three partitions (let's call it G:) but all of them use the same password. Sometimes I am able to mount all of them simultaneously (especially if I am doing that as early after logon as possible). But sometimes I have to enter password and mount every partition separately.
  6. Encrypted partition on drive D: seems to be stable, however partitions on drive G: are semi-dismounting without any notification.
First I tried to use for mounting letters from the end of alphabet, e g. starting from P:, however it does not work either - I still have the same problem(s). Then I decided to install VeraCrypt but the problem does still exist. Moreover VC sometimes "sees" just only one of three partitions on my disk G: and sometimes completely refuses to see E: one.

None of those problems were existing in my older computer. Could you help?

Feb 21, 2016 at 6:36 PM
Edited Feb 21, 2016 at 6:43 PM
Hello Kadett,

With all TrueCrypt/VeraCrypt volumes dismounted and using Windows Disk Management, do you still see a drive letters assigned by Windows to the non-system partitions that you encrypted in Disk Management?

If yes, remove the drive letters and reboot PC. Hopefully this will remove the issue that the partitions are in use.

Kind Regards.