This project has moved. For the latest updates, please go here.

System favourites don't mount on start-up (but mount on computer restart)

Topics: Technical Issues
Dec 18, 2015 at 10:39 PM
VeraCrypt (using `1.16 64 Bit), does not mount my system favourites on power-on start-up (Widows 10 64 Bit). It does however mount them on system restart start-up (after mounting them manually in VeraCrypt before restart).

I tried various things suggested in forums, incl. using diskpart to enable automount with no luck.

Is there some kind of debug setting where VeraCrypt logs what it does and where it fails to do something it tries?

Other things of note:
  • I previously used TrueCrypt with Windows 7 with the same disks and TrueCrypt passwords without a problem -> i.e. keyboard layout etc is not the issue.
  • I use a non-standard PIM (as the default is much too slow on my old machine)
  • My system drive is a SSD, the system favourites are on other, traditional HDDs (maybe they are not ready yet and VeraCrypt times out?)
  • The system drive was encrypted with VeraCrypt, on Windows 10, the system favourites with TrueCrypt on earlier Windows 7. After upgrade to Windows 10, password was reset with VeraCrypt on HDDs (but same password), but I did not reencrypt the HDDs.
  • I seem to remember that occasionally, rarely mounting system favourties also works on power-up startup, but I'm not 100% sure.
Dec 19, 2015 at 5:04 PM

Make sure you have the following settings enabled in Settings > Preferences:
  • VeraCrypt Background Task > Enabled
  • Actions to perform upon logon to Windows > Start VeraCrypt Background Task
Another possible issue is that the registry entries from TrueCrypt are overlapping the VeraCrypt if you performed conversion of the volume or if you used VeraCrypt 1.15 version in the past. Try the following procedures to eliminate any issues described in the above statement.

With the all volumes dismounted, perform the following.

Using a modified version of Idrassi's instructions:
Check the registry key "HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices" using regedit. Scroll down and you'll find entries starting with "\DosDevices\" which indicate the drive letters that are taken by the system. Before mounting any volume, double click on each one and remove the ones contains the name "VeraCrypt" and "TrueCrypt".
Also, there are other entries whose name start with "#{" and "\??\Volume{": double click on each one of them and remove the ones whose data value contains the name "VeraCrypt" and "TrueCrypt".
Reboot PC.
Jan 7, 2016 at 3:32 AM
Edited Jan 7, 2016 at 3:33 AM
Thanks for your reply and suggestions.

In short, it did not solve the problem.

In more detail:
  • I checked the settings and they had already correctly been set to the suggested values.
  • I found several TrueCrypt and VeraCrypt entries in the registry. I deleted them all (I'm pretty confident) as suggested.
  • I rebooted the machine.
At first it looked good and I thought the problem was solved. The volumes mounted successfully from cold start as well as reboot. However over the following days/ weeks it became apparent that this was either temporary or a statistical fluke: The volumes started not mounting on start-up again.

Some further observations I could make in the mean time:
  • My assumption that mounting would always fail on cold start but work on reset turned out to be wrong: Mounting also sometimes works on cold start, and sometimes fails on reset. I still think, probability of failure on cold-start is higher, but not sure if there is enough statistical evidence for this claim.
  • It always succeeds with all (both) non-system partitions or none. I have never observed only one mounting and not the other.
  • If the partitions fail to mount on start-up I can manually mount them successfully (Mount favourites). However, I have to re-enter the password (although it should be cached in the driver).
  • At least once, I experience the case where the volumes did mount during start-up but after a few hours of up-time suddenly disappeared.
  • Deleting the registry entires again did not make any difference (I didn't expect it to do so, but did so just in case)
Jan 28, 2016 at 10:51 PM
All the symptoms point toward a Windows feature called "Fast Startup" (or also "Hybrid boot and shutdown") was introduced in Windows 8 and that has been enforced on Windows 10.
I have talked about this in case of Windows 8 (still applied to Windows 10):

There was a discussion about it here:

Basically, it is not a VeraCrypt issue. You just need to disable Fast Startup in Windows 10 as explained here: