This project has moved. For the latest updates, please go here.

Windows: Cannot mount on drive letter H only.

Topics: Technical Issues
Oct 13, 2015 at 7:14 PM
While mounting a container to drive letters in Windows 7 generally works, it fails for drive letter "H". Actually it shows as mounted in VeraCrypt, but "H:" never appears in the Explorer and is not accessible from the command line either. Using VeraCrypt 1.16.
Oct 14, 2015 at 5:01 PM
Edited Oct 20, 2015 at 2:53 PM
EDIT:
For other users, first upgrade to latest version 1.16 or higher.

With the all volumes dismounted, perform the following.

Using a modified version of Idrassi's instructions:
Check the registry key "HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices" using regedit. Scroll down and you'll find entries starting with "\DosDevices\" which indicate the drive letters that are taken by the system. Before mounting any volume, double click on each one and remove the ones contains the name "VeraCrypt" and "TrueCrypt".
Also, there are other entries whose name start with "#{" and "\??\Volume{": double click on each one of them and remove the ones whose data value contains the name "VeraCrypt" and "TrueCrypt".
.
Reboot PC.
Oct 15, 2015 at 6:39 PM
Many thanks, Enigma2Illusion! The workaround resolved my problem. However, shouldn't this be taken care of by VeraCrypt?
Oct 15, 2015 at 7:15 PM
Did you ever use 1.15 or 1.15 beta version?

If yes, the 1.15 version caused the problem.

Did you have DosDevice\H and was it owned by TrueCrypt or VeraCrypt and point to the H letter when you clicked on that item?
Oct 19, 2015 at 2:25 PM
The answer to both of your questions is "yes".