Pretest Fail: Bios Reserved too much Memory

Topics: Technical Issues
Sep 17, 2015 at 12:17 AM
Hi, I've been trouble shooting a new laptop for almost a week now and I cannot pass the Veracrypt Pretest. I keep getting the Bios Reserved too much Memory message. Does anyone have any advice or similar situations?

Some background info:
The Computer is a Asus X553M, which is a UEFI Windows 8.1 machine running a GPT Harddrive out of box. I converted the harddrive into a MBR Partitioned Windows 7 machine and in the process of setting this up I had to disable Secure Boot and enable Compatibility Support Module (CSM) in the BIOS.

What I have done to help:
I have updated all the drivers and the BIOS to the latest version and currently only have 114 MB of Hardware Reserved Memory on the machine and can still not pass the pretest.

I've gotten Computers with worse stats to run Veracrypt:
My First Computer [offline only computer], a Lenovo X100e (with no BIOS updates or driver updates) was able to run veracrypt encryption and passed the pretest with no hitches, it also currently has 250 MB of Hardware Reserved Memory.
Sep 17, 2015 at 6:01 PM
Try Google searching using the following:
truecrypt and "Bios Reserved too much Memory"

Likely, you are going to need to disable RAID or some other BIOS setting to free memory since it is unlikely you can get ASUS to optimize the BIOS memory usage.
Sep 17, 2015 at 10:06 PM
Edited Sep 17, 2015 at 10:06 PM
After spending another day on it, I decided to return the computer, there isn't a cost effective solution to running Veracrypt on the Asus X553M.

I contacted ASUS about the problem and there wasn't a solution I could make with the BIOS settings, the BIOS is severely limited in options and the computer does not run well on Windows 7 OS.


A recommendation anyone who wants to try to run Veracrypt on a Asus X553M or X553MA, I believe I have a possible solution:

BIOS Settings:
  • Disable Secure Boot
  • Enable CPM
  • SATA in IDE mode (might be work arounds on this setting, I could not format MBR in AHCI mode)
OS:
YOU MUST RUN WINDOWS 8.1
  • The Computer has major driver and other hardware issues if you downgrade to Windows 7
  • However since the computer is native to GPT Partitions (as is Windows 8.1), you will need to reformat the hard drive with MBR in the Command Line and re-install the OS on it.
  • Alternatively you can downgrade to Windows 7 and reformat the hard drive to MBR in the Command Line, then Upgrade to Windows 8.1.
    • This has worked with ASUS users running Truecrypt.
Notes:
Upgrading the RAM does not help (8 GB RAM had the same problem)


I'm going to stick with Lenovo and avoid UEFI from now on. Too much trouble.
Coordinator
Sep 17, 2015 at 10:56 PM
Edited Sep 17, 2015 at 10:56 PM
The BIOS memory that is usable during boot is very small: less than 1MB (http://wiki.osdev.org/Memory_Map_%28x86%29).

VeraCrypt bootloader calls a BIOS function to determine the amount of usable lower memory and the error message indicates that there is not enough, which can happen on buggy BIOS.

Did you use AES as encryption algorithm?

AES has the lowest memory requirement (28 KB) and cascade ciphers have the highest memory requirement (42 KB). Thus, in situations where the BIOS takes too much memory for itself, it is better to use AES to avoid any issues.

If even with AES you get the memory error, then there is nothing that VeraCrypt can do. The only solution is to look for a better motherboard.
Sep 17, 2015 at 11:08 PM
This was done on AES only.


The experience with the Mobo was a nightmare, I would recommend avoiding the lower end ASUS laptops to anyone who is interested in economy or burner laptops.

I've gotten Veracrypt to run on $25 6-8 year old refurbished lenovos with zero problems.


BTW thank you so much for the information, I am new to the field of cryptography and this will help me out a lot in the future.
Apr 7, 2016 at 7:00 PM
Edited Apr 7, 2016 at 7:02 PM
Scary_Black wrote:
A recommendation anyone who wants to try to run Veracrypt on a Asus X553M or X553MA, I believe I have a possible solution:

BIOS Settings:
  • Disable Secure Boot
  • Enable CPM
  • SATA in IDE mode (might be work arounds on this setting, I could not format MBR in AHCI mode)
OS:
YOU MUST RUN WINDOWS 8.1
  • The Computer has major driver and other hardware issues if you downgrade to Windows 7
  • However since the computer is native to GPT Partitions (as is Windows 8.1), you will need to reformat the hard drive with MBR in the Command Line and re-install the OS on it.
  • Alternatively you can downgrade to Windows 7 and reformat the hard drive to MBR in the Command Line, then Upgrade to Windows 8.1.
    • This has worked with ASUS users running Truecrypt.
I do all these steps and got the same error: Bios Reserved too much Memory


Only way to resolve this - buy a new notebook?