This project has moved and is read-only. For the latest updates, please go here.

Incorrect password ?! Bachelor thesis on it - any way to help me?

Topics: Technical Issues, Users Discussion
Sep 16, 2015 at 2:01 PM
I recently installed veracrypt and set up a 14 character password, no PIM. The password includes numbers, a capital letter and a ! .

After setting it up my Samsung laptop restarted and veracrypt asked my to enter my password.
I did and windows 10 started loading. Next thing was that I encrypted it and the estimated time was 3 hours.
I though it was done when I left my university'a library but now that I have typed in my password x many times , tried typos etc ...I wonder whether maybe it was not yet 100 percent done when I shut down the laptop.

Could it be that this damaged somehow the system and therefore my password is repeatedly said as incorrect?

It say that I should use the rescue Disk. My laptop does not offer the option to burn such a disk that is why I planned to use an USB stick.
But before I could do that the library closed and I had to go home .

Now I am sitting here and can't use my laptop. .am about to cry. I am 99 p sure that I did not miss anything concerning my password.

I am writing mx bachelor's thesis and have a backup just like with all my other data... but all my literature quotes and content I extracted from x many books to use the information in my thesis is saved in the program CITAVI on my laptop. :(.

Please, I can't be the only one with this problem. .is there any way I can recover all my data or use some sort of back way??

I understand that the point of veracrypt is to make your data safe and that surely it won't be easy..if there is any way please help me!

Thank you very much :'-(
Sep 17, 2015 at 12:36 AM

The encryption process must always be deferred explicitly before shutting down the machine or rebooting. A warning is displayed about this during the encryption. This is important to avoid any data low caused by a sudden interruption of the encryption process.

That being said, interrupting the encryption can not cause by itself the password verification error: the encryption header is written during the pre-test and since it succeeded to boot after typing the password at VeraCrypt bootloader, the header was correctly written to the disk.

At this stage, there are two possibilities:
  • Something corrupted the hard drive part containing the volume header (very unlikely).
  • You are just using the correct password.
In my opinion, the second possibility is the most probable. In some situations, people tend to forget or mix password content. In other situation, people make mistakes while typing in the keyboard specially if they don't use the "Display password" functionality and when they try the day after they don't type the same keys and they think the day earlier the hit the same keys. It personally happened to me to mix 'e' and 'r', and also 'p' and 'o', when I'm in a hurry or not very concentrated.

If you had copied the rescue disk, we could check if this is the issue. Now, the only is to try to find the correct password by guessing what kind of mistake you could have done while typing it the day earlier.

I'm afraid no one can give you a better solution. This sad situation shows the importance of burning/saving the rescue disk before the encryption is fully performed.
Sep 17, 2015 at 8:15 AM

Yes I am really angry with myself for trying to do various things at the same time and ending up with no rescue disk...
I have tried all kinds of variation of the password I remember ..I guess this means that I am missing 5 percent of it while thinking I am remembering the whole thing.

Is there a way in terms of using a brute force tool or sth. to try to figure out the correct password since I am sure I remember at least 80-90% definitely right?

Sep 17, 2015 at 7:13 PM
No, you just have to remember & type in the correct password. Also, a fundamental rule of computing is that you always make a backup copy before you start doing something drastic like installing / upgrading an operating system or encrypting vital data.
Sep 18, 2015 at 10:25 AM
Edited Sep 18, 2015 at 10:27 AM
Since you say your password has numbers, capital letter and a !
Maybe your laptop changes the keyboard layout on boot. The numbers and the ! could be on another key while on boot and then it's selectable from the "normal" key once Windows loads. Try searching different keys, maybe the numbers and the ! are in a different key.
Sep 18, 2015 at 1:45 PM

Thank you for this suggestion but by pressing F 5 I can see what I am typing e.g. making sure I type the letter I intended to.

Aren t there any brute force tools available that one could use right in the boot loader veracrypt ?

Sep 18, 2015 at 5:23 PM
You can contact the developer of OTFBrutusGUI to see if he is willing to modify his software for VeraCrypt volumes.