This project has moved and is read-only. For the latest updates, please go here.

Error copying video files on Veracrypt volumes

Topics: Technical Issues, Users Discussion
Jul 15, 2015 at 10:09 PM
I have a 32GB pen drive fully encrypted (full volume). I try to copy to it many video files and the problem that I have is that every time I try many of the files are copied with error. Some of them are directly unrecognized by the system (with funny characters in their names) and others give an error when I try to play the videos. What can be wrong? I tried several times and always with the same result. Even with TrueCrypt this happened to me.
Jul 15, 2015 at 10:40 PM
You probably have hardware errors in the flash memory of your pen drive.

Can you run "Repair Filesystem" on the mounted volume by right clicking on its entry on the list as shown on the screenshot below? This will launch a utility that will check for bad sector on the drive. Please post the results here.

Jul 16, 2015 at 4:29 PM
Thanks for your suggestion idrassi, I've done it, no errors found. maybe some kind of antivirus problem? Maybe the type of format i choose for de pen drive? (FAT 32)? I'll try results with "ExtremeCopy" or something like that...
Jul 16, 2015 at 6:24 PM
If you are copying files from NTFS formatted drives to FAT32 formatted drives, there are limitations as shown in the link below.
Jul 16, 2015 at 10:59 PM

I'm a little surprised because it should have reported at least few errors because there was a bug in the 1.0f-2 that was causing a false error when you use "Repair Filesystem". Did you really run "Repair Filesystem" or "Check Filesystem"?
Jul 20, 2015 at 4:34 AM
I'm having the problem with large files, or when I try to copy a set of files which togheter represents big volume of data (more than 600 MB, for example). With small files, and copying them one at a time, the problem does not happen. It is worth remembering that they are video files, then the player fails when trying to play, perhaps for some data copied corruptly.
Jul 20, 2015 at 4:19 PM
You may be encountering the following issue:
Jul 21, 2015 at 12:56 AM
Thank you all for your support. I'm thinking that the PEN DRIVE probably has hardware errors... it's a generic USB pen drive and it's most probably that.. I'll try with another one...
Thanks again,
Jul 22, 2015 at 4:22 AM
Confirmed: it was a hardware (PEN DRIVE) error... Thank you all!!!!