This project has moved and is read-only. For the latest updates, please go here.

Installation issue with VeraCrypt Linux Setup

Topics: Technical Issues
May 16, 2015 at 2:21 PM
I am having serious issues while attempting to install the Linux version of veracrypt on both a 32bit and a 64bit linux system and am unable to figure out what is happening. The download I am using is this one from the veracrypt Downloads page here:-

VeraCrypt Linux Setup 1.0f-2
galahad@avalon $ uname -a
Linux avalon 3.13.0-37-generic #64-Ubuntu SMP Mon Sep 22 21:30:01 UTC 2014 i686 i686 i686 GNU/Linux
galahad@avalon $ ls -l
-r-xr-xr-x 1 galahad galahad  3338564 Apr  6 19:04 veracrypt-1.0f-2-setup-console-x64
-r-xr-xr-x 1 galahad galahad  3337422 Apr  6 18:58 veracrypt-1.0f-2-setup-console-x86
-r-xr-xr-x 1 galahad galahad  4584351 Apr  6 19:03 veracrypt-1.0f-2-setup-gui-x64
-r-xr-xr-x 1 galahad galahad  4537554 Apr  6 18:56 veracrypt-1.0f-2-setup-gui-x86
-rw-r--r-- 1 galahad galahad 15854443 May 16 13:29 veracrypt-1.0f-2-setup.tar.bz2
galahad@avalon $ ./veracrypt-1.0f-2-setup-console-x86
Verifying archive integrity... All good.
Uncompressing VeraCrypt 1.0f-2 Installer..
./veracrypt-1.0f-2-setup-console-x86: 1: eval: ./veracrypt_install_console_x86.sh: Permission denied
I have tried variously using root to install it via sudo, and changing the permissions on the compressed installer and using the gui installer but to no avail. I cannot see anything in logs that indicates an obvious issue. Any assistance would be appreciated.
May 16, 2015 at 3:21 PM
This is something unusual...I can't reproduce it on my Linux boxes.

Can you please run "./veracrypt-1.0f-2-setup-console-x86 --noexec
--target ."?
This will extract veracrypt_install_console_x86.sh to your current
directory. From there, try to launch it directly by typing
./veracrypt_install_console_x86.sh.
Does it work better?
What are the properties of the file veracrypt_install_console_x86.sh?
May 16, 2015 at 5:15 PM
Okay! I ran the command you gave me and yes it did extract the shell installer file to the current directory. I ran that file and it installed ok and it is living in /usr/bin/veracrypt and /usr/bin/X11/veracrypt and /usr/share/veracrypt respectively. However, when I run the command 'veracrypt' from the prompt I get the following error
galahad@avalon $ veracrypt
veracrypt: error while loading shared libraries: libfuse.so.2: cannot open shared object file: No such file or directory
Hmmm ... libfuse.so.2 ... I'm running Linux Mint by the way. Debian packages is telling me that that file lives in /lib/x86_64-linux-gnu/ and when I run a 'find' on it it's there alright. So i had a closer look and bingo ...
galahad@avalon $ ls -l /lib/x86_64-linux-gnu | grep libfuse.so.2
lrwxrwxrwx 1 root root      16 Oct 19  2014 libfuse.so.2 -> libfuse.so.2.9.2
-rw-r--r-- 1 root root  239736 Dec 16  2013 libfuse.so.2.9.2
In reply to your question about the properties of ./veracrypt_install_console_x86.sh ... I find the following :-
galahad@avalon $ ls -l veracrypt_install_console_x86.sh
-rwxr-xr-x 1 galahad galahad  3351724 Apr  6 18:58 veracrypt_install_console_x86.sh
So there you have it, they've removed libfuse.so.2 and replaced it with libfuse.so.2.9.2. And that's a programming issue, so I'm scuppered unless I can build it from source and make an appropriate change in a make file or something, but I have a feeling its a bit more complicated than that ...
May 16, 2015 at 5:27 PM
Are you running a 32-bit Linux or 64-bit Linux?

It appears you are installing the wrong version of VeraCrypt since you seem to run 64-bit Linux. Installer 64-bit VeraCrypt and it should load correctly.

By the way, VeraCrypt has been tested successfully on Linux Mint 17.1 Rebecca 64-bit by myself and other users.
May 16, 2015 at 5:30 PM
Duh ... oh wait. I moved from the 32bit machine to the 64bit machine and installed the x86 version instead of the x64 version. Now that I have corrected that monumental faux pas ... it's running :-) in console mode. So now I've installed the gui version as well and bingo there too. I'm up and running. Cooool. Thanks idrassi,

I read your documentation and I was very impressed with what you've done with veracrypt in relation to the testing that was done on the former TrueCrypt etc. and the changes you made. I've got VeraCrypt running on a Windows box as well and that is running sweet as a nut. Great job, thanks a million.